Scan to PDF App?

Is there some app like gscan2pdf to OpenSUSE 12.1 (gnome)?
I’m using Xsane but each scanned page even in gray mode get almost 1MB. Can I just configure Xsane or there are some other apps?

The first thing I see when starting Xsane is a window where I can configure many things and among them is Scanresolution. I guess that playing around with that will infuence the size of the file generated.

I use KDE, but I guess that Gnome does not cripple Xsane beyond recognition :wink:

Also if you just want to scan text you should experiment with thresholding to force the image to black and white, which reduces the number of gray levels and thus the size. IIRC you can also scan from within GIMP.

And there is Skanlite. Buit I guess that in all cases you have to tell the program what resolution and how man levels you want when the defaults do not fit your needs.

gscan2pddf will install on openSUSE - follow these instructions:

  1. From YaST, select Software Repositories
    a. Add the perl repository: Index of /repositories/devel:/languages:/perl/openSUSE_12.1
    b. Add the build service repository from openSUSE user illuusio: Index of /repositories/home:/illuusio/openSUSE_12.1
  2. From YaST, select Software Management
    a. search gscan2pdf. Install the package and its dependencies

If you prefer to use zypper:

zypper ar http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_12.1/ perl.12.1
zypper ar http://download.opensuse.org/repositories/home:/illuusio/openSUSE_12.1/ illuusio.12.1
zypper in gscan2pdf

I installed gscan2pdf but when I try to star it, it just doesn’t start. I assume there something missing, but I don’t know what.

You should allways document your problem with facts, not with vague stories.

Thus please post here all and everything (between CODE tags) what you get when you call

gscan2pdf

On 2012-01-06 14:36, hcvv wrote:
> I use KDE, but I guess that Gnome does not cripple Xsane beyond
> recognition :wink:

Xsane is not a KDE app nor a Gnome app, so it is not affected by what
desktop you use.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Hi Volter -

Try installing the perl-Gtk2-Ex-Simple-List package:

  1. If you haven’t already got the perl repository added:
zypper ar http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_12.1/ perl.12.1
  1. Install the package:
zypper in perl-Gtk2-Ex-Simple-List

Sorry I didn’t include that in the earlier instructions. According to the gscan2pdf man page, the program won’t run without this simple-list package, but it looks like it’s not handled by the dependency resolution when you first install from YaST or zypper. Let me know if you have any more trouble.

Andy Prough
Kyle, TX

I installed ‘perl-Gtk2-Ex-Simple-List’

When I try to start gscan2pdf I get this :open_mouth:

Can't locate Gtk2/Ex/Simple/List.pm in @INC 
(@INC contains: /usr/lib/perl5/site_perl/5.14.2/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.14.2 
/usr/lib/perl5/vendor_perl/5.14.2/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.14.2 /usr/lib/perl5/5.14.2/i586-linux-thread-multi /usr/lib/perl5/5.14.2 
/usr/lib/perl5/site_perl/5.14.2/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.14.2 /usr/lib/perl5/site_perl .) 
at /usr/lib/perl5/vendor_perl/5.14.2/Gscan2pdf/Document.pm line 6.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.14.2/Gscan2pdf/Document.pm line 6.
Compilation failed in require at /usr/bin/gscan2pdf line 131.
BEGIN failed--compilation aborted at /usr/bin/gscan2pdf line 131.

So:…whats the problem?

Hmmm… Now you’ve got me stumped. I can’t recreate the problem on my system - gscan2pdf is working fine for me with those packages. You might have to try

man gscan2pdf

and review the dependencies, and try to check your system to see if you are missing any of the perl dependencies? Have you tried simply re-starting your system?

To the op, in Xsane when you scan to pdf, what resolution were you using?

Edit:

I tried to scan a letter size using black & white @ 300 DPI.
The PDF is only 119.4 KB
The page I scanned contains the cup printer test output.
Reducing the 300 DPI to 200 maybe will have less.

Save some headache on gscan2pdf, we have simplescan, zypper in simple-scan. On text mode we can always choose what output and what dpi we want to save to either to jpeg, png or pdf.

Many thanks to all from Italy,
I was able to install, scan and save on Suse 13.1

(problems with perl dependencies)