scan configuration with Samsung SCX-3205

Hello,

I can’t configure the scan part of my multifunctional printer Samsung SCX-3205. The printer part works fine, but no way to make the scan part working.

The scan works on leap 42.3 but don’t on leap 15 (on several pc desktop and laptop).

Here is the dmesg just after plug in of the printer.

 6250.216779] usb 1-6: new high-speed USB device number 12 using xhci_hcd
 6250.370251] usb 1-6: New USB device found, idVendor=04e8, idProduct=3441
 6250.370252] usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
 6250.370253] usb 1-6: Product: SCX-3200 Series
 6250.370254] usb 1-6: Manufacturer: Samsung Electronics Co., Ltd.
 6250.370254] usb 1-6: SerialNumber: Z5EXBFCBA02233T
 6250.372275] usblp 1-6:1.1: usblp0: USB Bidirectional printer dev 12 if 1 alt 0 proto 2 vid 0x04E8 pid 0x3441
 6255.514179] usblp0: removed
 6255.519979] usblp 1-6:1.1: usblp0: USB Bidirectional printer dev 12 if 1 alt 0 proto 2 vid 0x04E8 pid 0x3441

The “usblp0: removed” look strange to me because I don’t unplug the printer.

Scanimage -L two times in a row give

user@ordi:~> scanimage -L
device `xerox_mfp:libusb:001:011' is a Samsung Samsung SCX-3200 Series multi-function peripheral
user@ordi:~> scanimage -L


No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).

Of course the yast configuration of the scanner doesn’t work.

I don’t know what to do :frowning:

If someone can help me, it would be nice.

I have little experience using flatbed scanners with Linux except one Mustek device, connected via SCSI, using SANE (»Scanner Access Now Easy«). But in a pinch, I recently found my smartphone camera easily good enough for digitizing a few pages. Just go to a well-lit place, hold the phone steadily, snap a few pics (with and without flash, for comparison), then copy it to your Linux machine via Bluetooth or USB/adb.

Searching for Linux-specific driver software for Samsung SCX devices, I found the »Samsung Unified Linux Driver User’s Guide« http://www.electis.co.il/files/Docs/LINUX/Samsung_ULD_UsersGuide1.1_English.pdf — nothing Leap-specific (the PDF mentiones only 13.1 and SLED 11 as it’s published 2014-03), but on page 24 it implies your SCX-3205 ought to work.

Since you mentioned it worked with 42.3: did it work out of the box with cups & SANE, or can you remember installing anything additional? Or configuring anything along the steps from page 15 onwards (Xsane etc.)?

Thanks for the smartphone tip, but, well, using my scanners would be nice too ;).

I try also with Samsung Unified Linux Driver with same result. If I remember well, in 42.3 it’s even working without installing the samsung driver (or just the one proposed by yast).

In my opinion there is a problem with usb managing, something related with xhci-ehci or usb3-2 but it’s beyond my linux skill :frowning: I tried to use setpci command with no success.

I found this thread with similar problem

https://forums.opensuse.org/showthread.php/504397-USB-Scanner-disappears-after-some-seconds-of-system-runtime

Anyway, thanks for your time.

It’s interesting that ‘scanimage -L’ detects the attached scanner the first time. Ignoring the fact that scanimage -L’ does not detect the attached scanner the second time it’s run, can you use xsane, simple-scan (or some other scanning application) with it successfully?

Another thought - if the multi-function device is power cycled, does the scanner then work as expected?

The first time (before any acces to the scan device) I can launch xsane, then, after clicking on the button to obtain the draft, xsane send an error message.

https://i35.servimg.com/u/f35/11/15/74/21/th/xsane110.png](https://servimg.com/view/11157421/202)

When I launch xsane for a second time, I got an error message immediately (“no device available” something like that) .

https://i35.servimg.com/u/f35/11/15/74/21/th/xsane210.png](https://servimg.com/view/11157421/201)

I’m not sure to understand what you mean. If I wake up the scan by pressing a button on the printer, there is no improvement.

I also look at these thread to try to understant what’s going on, but I don’t garanty they’re relevant.

Scanner not detected - Applications - openSUSE Forums?

https://forums.opensuse.org/showthread.php/507627-Suse-13-2-scanner-no-longer-working-on-64-bit-version?p=2714695#post2714695

Hi,

Some news.

I think there is something wrong (for my scan device at least) with the default leap 15 kernel : 4.12.14-lp150.12.45-default.

I just installed the 4.20.10-lp150.3.g4c06520-default from https://download.opensuse.org/repositories/home:/pgnd:/Kernel:/stable/openSUSE_Leap_15.0/ and scanimage -L works two times in a row.

[FONT=arial]For now i’m with no graphical interface because I must reinstall the nvidia driver.
[/FONT]

Hi,

I installed the nvidia driver, stay in kernel 4.20 and everything works fine.

Thanks for help.

Why Installation of an kernel from a /home Repo and not from kernel:stable?
https://download.opensuse.org/repositories/Kernel:/stable/standard/

You’re right, it was just to try, I take the first repo I found … I switched to kernel:stable now :slight_smile:

Thanks.