SB!Live OEM not detected

I have tried /sbin/lspci and no joy. My sound card isn’t listed there at all.

The card hasn’t moved in its slot from where it was when this machine ran XP. The sound worked great then.

Any suggestions that may help my v11 OpenSuse detect the card?


BTW … The chipset is CT4832 10K1 … if that helps.

It is fundamental that lspci detect your card (unless it is a usb device). If it is usb it should be detected by “lsusb” (requires usbutils), but you state “card hasn’t moved from in its slot” so I assume then it is PCI. (and hence should be detected by “lspci”)

Did you try booting to fail safe to see if your card is detected then?

Do you have mother board sound? If so, what happens if you switch OFF the mother board sound in BIOS? (in truth, IMHO this should make no difference to the PCI card detection).

Please can you confirm that the card is seated properly? ie. with the power OFF, open the case and confirm the card is firmly in place. Close PC, and try powering it again. If that doesn’t work switch OFF power, and try this with the card in a different slow.

Any chance the card is non-functional? Maybe zapped by static electricity when you were cleaning the interior of the PC ?

You could download a liveCD (that specializes in hardware detection), such as sidux or kanotix, burn and boot to the CD, and see if your card is detected with them …
sidux :: debian based live cd development
kanotix :: GNU Linux Live system based on Debian, optimized for HD-install and high performance

I looked, and I did not see your chipset on the Linux incompatibility list:
SB!Live OEM not detected - openSUSE Forums

Thanks very much. One of your suggestions worked, I tried them all but my gut feel is that reseating the card did the trick. thanks again.