SB Audigy SE various problems--sound doesn't work period

Hello, previously I had some trouble with my SB Audigy SE, and I guess deleting the card in YaST Sound, and then adding it again fixed it. Well this time its a different story. I am running on the same system with a different install of openSUSE, and once again my sound doesn’t work.

Following the same procedure as before does nothing. speaker-test makes no noise, mplayer makes no noise. alsaconf says it can’t find any supported PCI cards and there IS NOT a /proc/asound directory, therefore /usr/sbin/ only returns “No such file or directory” for all 4 commands.

Now here’s the stupid part: the sound worked last night when I shut my computer down. This morning I boot up and… nothing.

Hey, guess what’s really really funny?

I accidently stepped on the power button on my surge protector, and when I turned my computer back on, sound worked again >.<

Actually, I think it has something to do with IEC958 possibly, because I found a GUI for alsamixer called gamix and there’s a little radio button for IEC958. When it’s checked, sound works and when I disable that, sound magically disappears again…

Not sure, but that’s my best guess…

Have fun!
– Vi3

Nice it works again. But please next time you come here with a question/problem do not forget to tell which openSUSE level you use (in any case more precise then “… with a different install of openSUSE,”) and which desktop environment (KDE, Gnome, other).