SB 0162 no mic work on Leap 15.2


OS Leap 15.2

lspci output :

Multimedia audio controller: Creative Labs EMU10k2/CA0100/CA0102/CA10200 [Sound Blaster Audigy Series] (rev
Subsystem: Creative Labs SB0162 Audigy ES
Flags: bus master, fast Back2Back, medium devsel, latency 32, IRQ 16
I/O ports at 2000 [size=32]
Capabilities: [dc] Power Management version 2
Kernel driver in use: snd_emu10k1
Kernel modules: snd_emu10k1

The problem is that mic not work and not detected when plug it. How to solve ?


Can you change something in pavucontrol?

Shows only output devices, not input

In alsamixer possible change mic gain, but no effect

Have you choosen input and output (Stereo duplex) in the Configuration Tab for your card?

the problem is that system doesn`t know input device

Have you switched in pavucontrol to duplex?

How to do this ?

arecord --list-devices
**** List of CAPTURE Hardware Devices ****
card 0: Audigy [SB Audigy 1 ES [SB0160]], device 0: emu10k1 [ADC Capture/Standard PCM Playback]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Audigy [SB Audigy 1 ES [SB0160]], device 1: emu10k1 mic [Mic Capture]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Audigy [SB Audigy 1 ES [SB0160]], device 2: emu10k1 efx [Multichannel Capture/PT Playback]
Subdevices: 1/1
Subdevice #0: subdevice #0

If I add

load-module module-alsa-source device=hw:0,0

in mic work, but output hides )) How to enable both ?

With this module loaded I have tested mic. Then I comment this directive and restart pulseaudio. After output devices showed, I ran aplay tool and check tha mic hardware work properly. For now the task is how enable mic and output both

See here in pavucontrol:

pulseaudio is running in user context, so pavucontrol must be run also as user.

There is no duplex value. Only stereo output ( enables output) or stereo input ( enables mic ), but no both input and output. How to enable both ?


I found profiles at /usr/share/pulseaudio/alsa-mixer/profile-sets/

I have renamed force-speaker-and-int-mic.conf to default.conf ( or you can make symlink)

After pulseaudio restarted, I found new profiles and analog audio duplex also.

For now everything work