sax2 crashes on each bootup

Sorry, misread the post.
Just check the file, there is nothing. empty.

That is not possible.
You need to be su to open and read

Yup, it is empty.
I open it through terminal through su by gedit.

OK
Go to Yast - System - Bootloader

On the default opensuse11 option - choose edit
and copy and paste here all the info from the various fields
do the same for failsafe

For openSUSE 11.0,
Section Name:

openSUSE 11.0 - 2.6.25.11-0.1

Optional Kernel Command Line Parameter:

resume=/dev/sda1 splash=silent showopts

Kernel Image:

/boot/vmlinuz-2.6.25.11-0.1-default

initial RAM disk:

/boot/initrd-2.6.25.11-0.1-default

Root Device:

/dev/sda2

Vga Mode:

0x305

For failsafe,
Section Name:

Failsafe – openSUSE 11.0 - 2.6.25.11-0.1

Optional Kernel Command Line Parameter:

showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off x11failsafe

Kernel Image:

/boot/vmlinuz-2.6.25.11-0.1-default

initial RAM disk:

/boot/initrd-2.6.25.11-0.1-default

Root Device:

/dev/sda2

Vga Mode:

0x305

It looks OK
The only thing I would say looks unexpected is Vga

I would have expected: vga=0x31a

But I still can’t understand you not having a valid menu.lst

Are you using a separate boot medium? Or anything other than the normal grub bootloader to the mbr?

Nope, i am using the default boot loader.

Can i change this:

I would have expected: vga=0x31a

Yes in Yast system boot loader

normally I would say edit menu.lst But you don’t seem to have it!

I’m not sure it will help, but you can always change it back

Thanks for being with this thread.
will try it and will be back with the results.