Sax does not find ttyUSB0


I have an old WACOM Intuos tablet with a serial interface that I want to use with my Linux machine, but it only has one serial adapter, which is already used for my external modem; so I got a USB-to-Serial adapter that plugs into a USB port.

With the wacdump program I can see data coming in from the tablet to /dev/ttyUSB0, but when I run Sax to add it to the X configuration it lists only USB and /dev/ttyS? ports, but no /dev/ttyUSB? ports.

I looked through all the documentation I could find for Sax and sax2, but could not see anything about specifying additional ports. Is there a command-line option or configuration file that can be used to provide this information?



Looking in /dev on my system, I cannot find ttyUSB. Does it exist in your /dev folder?

The device will only exist after the USB serial adapter module is loaded. OP, I assume that the device file appears after the adapter has been plugged in. I suppose worst comes to the worst you could make a symlink to the name expected in the config file /etc/X11/xorg.conf.

/dev/ttyUSB0 appears in /dev

[19:34:57 turriff@buckskin:~/Documents/Code]$ ll /dev/ttyUSB*
crw-rw---- 1 root uucp 188, 0 2009-03-04 13:08 /dev/ttyUSB0
crw-rw---- 1 root uucp 188, 1 2009-03-04 13:08 /dev/ttyUSB1

and I can use the wacdump program to see the data that it sends to the system. The problem is that YaST and Sax do not allow for serial devices other than USB and ttyS? and do not allow one to enter arbitrary /dev paths for them.

I will be grateful for any help you might come up with. Perhaps this should be posted as a bug report?


I am having a very similar problem.

I am using openSUSE 11.1 on my iMac G5 PowerPC. I’m trying to get my Wacom Intuos GD tablet to work, using either a Keyspan USA-19hs USBSerial adapter or an old Prolific pl2303 USBSerial adapter. No luck yet.

When I run the: lsusb command I can see the adapter in the list. That line reads:

Bus 003 Device 002: ID 06cd:0121 Keyspan USA-19hs serial adapter

But, in Sax2 none of the Ports give me any functionality with the tablet.

I can’t find specific drivers for either the Prolific or the Keyspan adapter in openSUSE or elsewhere.

Anyone know any tricks…can I treat the USBSerial adapter as a standard USB 2.0 plug?

Is there a repository of USB-Serial adapters for openSUSE?

I’m really hoping that openSUSE can work with my tablet;)

What exactly is the USB serial module?

Where can I get it?


The module name for the fairly widespread Prolific chip is pl2303. Normally it should be automatically loaded when the adapter is plugged in.

OK…should I see the pl2303 module recorded in the Xorg.o.log file?

How do the linuxwacom-0.8.2 drivers work with the pl2303?

How do the x11-input-wacom, x11-input-wacom-devel, and x11-input-wacom-tools function with the linuxwacom and pl2303 drivers?

I tried the steps in this post for USB Wacom tablets with no success.

Does anyone know if the linuxwacom-0.8.2 drivers are compiled for a ppc64 architecture? The “Technical Data” tab in YaST says that they are…is that correct?



I figured this out…Wacom Intuos GD working with pressure, tilt, etc…on openSUSE 11.1 ppc64.

You will have to make sure that the x11-input-wacom, and x11-input-wacom-devel, and x11-input-wacom-tools packages are installed.

Then modify your xorg.conf file found in: **/etc/X11/xorg.conf

Follow the instructions on this page:

The Linux Wacom Project

Most of the answers can be found on The Linux Wacom Project site:

The Linux Wacom Project

If your new to Linux, like I am, it will take some patience in order to understand which changes are logically appropriate for your device and set-up…but it is worth it!