sax and X11 disabled keyboard and mouse


I am quite experienced in installing openSUSE.
(I used it for many years.)
But the problem showed below tricks me out.

I just tried to install openSUSE 11.2.
In initmode 3 the keyboard works well.
Everything worked well up to the moment I started runlevel 5.
In XWindows Modus, the keyboard and the mouse are disabled.
And I cannot get back to any other Virtual console.

When I started sax2,
I get something (in the file /var/log/Sax.log)
for both mouse and keyboard like this:

Section “InputDevice”

Driver “kbd” will be disabled unless

‘Option “AutoAddDevices” “off”’

is set in “ServerFlags” section.

Driver “kbd”
Indetifier "Keyboard[0]
Option “protocol” “Standard”


It indicates , mouse and keyboard are disabled.

Here are my questions:
How can I ENABLE my keyboard and my mouse?
where is the file that configures sax2?
Do I have to set (“on”) the AutoAddDevices? or to “off”

Can anybody help me with that?



due to an entry in /var/log/Sax.log
and a related thread at this forum
I found a solution to the disabled mouse and keyboard.

As root, I called: (e.g. from roots home

Xorg -configure

cp /etc/X11/xorg.conf

Then I added to the just created /etc/X11/xorg.conf
the folowing section right betwen
the sections “Module” and “InputDevice”

Section “ServerFlags”
Option “AutoAddDevices” “on”

After that X autodetects the keyboard and mouse.

I will keep you on track,
whether this was the final solution,
or if new problems appear.

Hi folks,

Now the keyboard and mouse works well,
right after login into KDE.

Afters some minutes,
the Keyboard blocks again (no reaxction at all).
The mouse is still working.

A disabled the KDE-Screensaver and
disabled any PowerSaving, too.

It seems to work now,
as I don’t get these nasty keyboard blocking any more.

is it possible that
the Serverflag Option “AutoAddDevice” “on”
is not working
with Screensaver or after Power Save Aktivity??



I had the same problem, after a clean installation in the first Xwindows session the mouse and the keyboard seems to be frozen in the screen, I does not matter wich windows management use, nor kde neither wmaker, I tried testing from a level 3, and executing sax2 also that failed, after looks in the Sax.log messages I found all fine, but only the warning of the allowempty input and dissabling the mouse and the keyboard and some error in the last of the file regarding about the hal detection.

So after reading the man page of the Xorg.conf I tried to change several flags in the file the first one commented in the section server flags, so I decided to uncomment “AutoAddDevices” “off” because I read some lines later that the keyboard and the muse where there as typical InputDevices.

After restarting with that flag changed all worked fine I had mouse and keyboard again. Check that flag !

I wonder if that could be related to Bug 585617 - No keyboard/mouse