Sandisk SD card reader w/ 4GB card

Using OpenSUSE 11.1 64-bit (Including Xen) with 8GB RAM, Asus M2NPV-VM and Athlon 64-bit proc (3800+ I think).

I have a Sandisk multi-card reader that works great with my 1 & 2GB SD cards but it won’t recognize my 4GB card. The reader uses /dev/sdd(e,f,g) and when I put my 1GB card in the reader it pops up on /dev/sdf1. When I put my 4GB card in (works in my Canon camera), nothing.

I tried the same scenario on a Mac version 10.4.11 with the same results. I haven’t tried it on Windows yet. I don’t have Windows at home. :slight_smile:

Any help will be greatly appreciated.


If you do this in a su terminal:

fdisk -l

Try it with those that work and the 4GB
Does fdisk see it

fdisk -l sees my 1GB card with FAT16 partition on /dev/sdf1 but there is nothing when I insert the 4GB card.

I’ve just installed Win7 into a Xen HVM and configuring it now to recognize the USB. I’ll report back if Win7 can see it.


  • zorgeo,

4GB = microSDHC format. Many old readers can’t deal with such cards, I have one of these in my desktop machine, it is a hardware issue, not Linux related.


I was just going to post the same thing Uwe. I think there’s a firmware update for the card reader (Sandisk sddr-89). I’ll try it and post back my results.

Ok, what I discovered is that my version of the Sandisk 12 in 1 reader is not compatible with SDHC (SD card larger than 2GB). There was a firmware update but it didn’t correct the problem and Sandisk’s website said my specific model was not compatible with SDHC. Just bought another card reader so that should take care of it. Thanks for everyone’s help.