Samsung S7 Connection Issues

Since my upgrade from 15.3 to 15.4, I am now experiencing an issue when I connect my S7 to my PC. Previously I could access the device via KDEConnect just fine. Now, the phone shows connected and then immediately shows disconnected. Here is the excerpt from dmesg:

[46855.483280] usb 4-3: New USB device found, idVendor=04e8, idProduct=6860, bcdDevice= 4.00
[46855.483288] usb 4-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[46855.483290] usb 4-3: Product: SAMSUNG_Android
[46855.483292] usb 4-3: Manufacturer: SAMSUNG
[46855.483294] usb 4-3: SerialNumber: d48062df
[46856.691671] usb 4-3: USB disconnect, device number 19

This sequence goes on and on. I’m not sure how to debug this any further.

Similar thread here:
I assume that you’ve tried a different cable? Restarted the phone?

Some further things to eliminate from the equation…

Do all USB ports result in the same behaviour?

Check USB auto suspend isn’t causing an issue here perhaps. What is reported by the following command?

cat /sys/module/usbcore/parameters/autosuspend

Normally, KDE Connect connects via WiFi/WLAN → does a WiFi/WLAN connection function as expected?

I’m testing with my Pocket Telephone – switched off the WLAN/WiFi and, plugged in a USB to USB-C cable (I don’t have a “proper” USB to USB-C cable – I grabbed the one which came with the Pocket Telephone’s Charger … ) –

  • KDE Plasma recognized the Pocket Telephone via USB – mounting the Telephone failed until such time that, I noticed that, Android was requesting that I allow access to the Pocket Telephone.
    Once the Android permission had been granted, the Pocket Telephone was mounted and Dolphin can access the Pocket Telephones directories …

But, KDE Connect on the Pocket Telephone is telling me that, KDE Connect needs a WLAN (WiFi) Network and, KDE Connect on the KDE Plasma Desktop can’t find my Pocket Telephone.

So, as I suspected and, AFAIK, KDE Connect only supports connections via WLAN/WiFi and OpenVPN.

Troubleshooting here: <>

Rebooted the phone and changed the cord with still no luck. FYI, the initial cord I was using worked fine with 15.3.
The autosuspend option is reporting ‘2’.

I am assuming you are referencing the cell phone, and the answer is yes.

When you connect your phone with your PC via USB cable you can

  • access your phones data storage via MTP (e.g. with a file manager like dolphin).
  • access your phone via adb.
  • use your phone as a modem.
  • load your phones battery.

But KDE connect in order to work needs your phone being connected to the same LAN as your PC.

I can’t really see anything about the device other than it appears and then disappears in the Devices section of Dolphin. I tried the same under Gnome, but get the same behavior. Notifications tell me the device is connected and then disconnected, connected and then disconnected over and over.

And yes, the phone and the PC are on the same network.

Before looking at the log please clarify how you want to access your phone (from your PC):

  1. with KDE connect (as you told us in your post #1)
    then you do not need any USB cable connection between your phone and your PC
  2. in any file manager via MTP protocol
    then you have to establish an USB cable connection between your phone and your PC plus you have to enable the USB data transfer mode your phone.

Ideally I would use KDE Connect since I use KDE as my desktop, but if I have to use another mechanism, I am good with that as well.


Get rid of the USB errors by removing the USB cable connection PC/phone.

I do not use KDE connect but here is a basic description on how to proceed:

  • install KDE connect on your PC
  • install KDE connect on your phone
  • connect PC and phone via WLAN with the same network
  • pair the devices (PC & phone)

For a more detailed description see here.

I guess I need to apologize for my lacking of understanding here. I thought that KDE Connect used the USB connection to talk t the device which is apparently incorrect. I need to follow the link you sent to better understand just what I am doing :blush:

That is absolutely correct – KDE Connect connects only via WLAN/WiFi or OpenVPN.

Thanks for the confirmation. Aside from the KDE Connection, I am still not understanding why the connection cycles up and down so quickly when the phone is connected via USB. Any ideas on that one?

Did you investigate the things mentioned in posts #2 and #3?

I tried rebooting and a different cord the other day giving me the same results. I just now tried yet another cable, bu this time all appears good. I can’t believe I have two (2) bad cables, but I guess I do. What are the odds. Thanks everyone for your assistance.

All good. Does it behave consistently with the given cables? Thanks for the update.

I have at least one cable that does give me repeatedly good results. I guess I will have to keep note of the quality of cables.

1 Like

The USB cable is also a power cable – it charges to the Pocket Telephone’s battery.

  • Meaning that, the USB cable supplies sufficient electrical power to improve the performance of the Pocket Telephone.
    Your Pocket Telephone may well be suffering from a weak battery.

Cartoon in a British daily newspaper from – 1920

My experience is that some smartphones only “like” the cables which were originally supplied with the phone (or at least purchased from the smartphone manufacturer?).