Samsung ML2164 Laser Printer Driver for 13.1

I just purchased a Samsung ML2164 Laser Printer. Is there a driver which will make this printer work in 13.1? Where to get it from?

Check the Samsung site out for the Unified Linux driver

This thread (similar model discussed) might be useful too

In particular, the posts by zuchov and tobice…

On 01/13/2014 10:26 PM, stubble wrote:
> I just purchased a Samsung ML2164 Laser Printer. Is there a driver which
> will make this printer work in 13.1? Where to get it from?

If you have not already done so you can have YaST try to install the
driver for you from YaST > Printer

Was I helpful? Click that little star so that I can brag about it to my
invisible friends >:)
Bring the Penguins Back!

OK. I’ve downloaded the Linux Printer Driver V1.00.06. I’ve unarched it to a folder uld. Inside that folder are…

arm (folder)
i386 (folder)
noarch (folder)
x86_64 (folder) (this has an * after sh in a Bash console) (so does this)

I change to root and try to run from the uld folder but I get error (missing file operand). What operand should I add to get this driver to install? I have a 64bit 13.1 installed.

Any and all help appreciated.

Hmmm… in an effort to assist, I downloaded it, and ran the installer without issue

 # ./ 
**** Running install
**** Press Enter to continue or q and then Enter to quit:
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

**** Do you agree ? [y/n]: y
**** Registering cups backend ...
**** Are you going to use network devices? If yes, it is recommended to configure your firewall.
**** If you want to configure firewall, enter 'y'. To skip, enter 'n' or just press enter: n
**** CUPS restart OK
**** Registering SANE backend ...
**** Restarting udev ...
**** Install finished

Maybe you should capture the terminal output and post here like I did.

OK By trial and error, I’ve got this far…

change to the noarch folder
execuse …/
I get the Samsung Software License Agreement

How do I exit that and continue with the install?

This was posted before seeing your last post deano. I get back to you.

OK when I capture the output I see after the software license agreement

**** Do you agree ? [y/n]:

I do not see this line when I run the install without capture. I see the license agreement and don’t know how to exit that, in order to get to that prompt. I’m in Konsole at this point.

Just press ‘q’. Then you’ll be prompted with

Do you agree ? [y/n]:

Answer ‘y’…

BTW, if you’d read the thread I linked to earlier, it tells you the same

That worked. Thanks. Now to figure out how to get my printer installed :slight_smile:

I did take a look at those threads, but I must have glanced over that point. Thank you for your patience.

Great. Now configure the printer via the browser


Printer configured using Yast, but browser configuration looks easier. Thanks again

Nice work. Enjoy! :slight_smile:

Samsung provides a closed-source driver on their web site, the “Unified Linux Driver”, a driver package containing CUPS drivers and PPDs for all Samsung printers.

Cheap printing Singapore