Samsung ML-2010

I already use suse 11 x64 and i have a problem with my printer samsung lm 2010…i tried with Foomatic/GDI and seems to be that the job is done but nothing in the printer (it says Set…printing…set) later i tried with splix and when i print a page test it says “/opt/splix/cups/lib/filter/rastertospl2 failed” and with the samsung’s drivers too, same situation…and nothing seems to works no like suse 10.3 x32 where my printer works fine…is there a problem with Cups x64 or kernel?

this is what i use :
Linux linux-rcmk #1 SMP 2008-07-13 20:48:28 +0200 x86_64 x86_64 x86_64 GNU/Linux

it detects my usb’s printer i have no problem with that

thank you ::slight_smile:

Here’s a couple of links that list solved with a ML 2010:

Arch Linux Forums / [solved] samsung ml-2010, i can’t get it to work!
Printer Problems - Linux Forums

The only advice I would give over and above those is to reboot after you remove all the drivers & start with a clean system.

Google/Linux for “ML 2010” (not lm 2010):slight_smile:

Good luck.

thank you for you help…and yes i did that, remove all those drivers that cups has…after that restart and install again by yast, and the same history…and i tried with Port 631 also -.- suse detects my printer i have no problem with that :slight_smile:

I guess is the kernel, i was trying with debian and worked too…maybe is a bug :smiley: because i tried with live Cd Suse 11 gnome and the printer doesnt works

I guess is the kernel, i was trying with debian and worked too…maybe is a bug :smiley: because i tried with Suse 11 X86 and the printer does works perfectly, but still doesnt works in suse 11 64 bits

Have you looked on Samsung’s site for a Linux updated driver? I had a problem with an SCX-4200 and found newer files for it.

I have a Samsung ML-2010R connected to my servers USB port and it’s working perfectly. All I did was the following

Startmenu > Configure Printers
which took me to the printers window, selected the option on the left in the middle “Printers and Queues” (mentioning position since you might use a different language).

Add > Samsung > ML-2010

It’s been a while since I did it so I’m not sure if there were any more steps to it… but below I’ll list you the 2 items I’m shown when I got to the printers Configure > Basic Settings tab in the Driver field. (Which probably is the information you’re after)
Samsung ML-2010 Foomatic/gdi (recommended)(Samsung/ML-2010-gdi.ppd.gz)
Samsung ML-2010, 1.0 (Samsung/ml2010.ppd)