Samsung ML-1665 Landscape problem

Hi :slight_smile:

I have just updated from a 32bit version of OpenSuse 11.4 to the shiny new 64bit version of OpenSuse 12.1 and love it already. Unfortunately my Samsung ML-1665 printer seems unhappy!

While using 11.4 I had installed the Samsung unified Linux driver 0.86 and the printer was very chirpy and printed well (not perfectly, but very well).

Now I’ve installed 12.1 and have again installed the Samsung unified Linux driver 0.86 and the printer prints fine again except it prints everything in portrait mode. I have tried old and new Oo documents which are in landscape mode and they all print in portrait :frowning:

Can anybody help me out please?

Many thanks

I have one of those, under 11.4 64bit + KDE 4.x. The first time I installed the samsung proprietary drivers I noticed that on non-kde-native apps, after their print dialog, would call the (quite ugly, tk-style) samsung print dialog, and that this settings would be applied over the app print settings. Later I found out I could prune most of the driver “goodies” and have the printer behave. If you think this may help you with your 12.1 issues see this post and perhaps a few before and after it.

Thanks brunomci. I have reverted back to OpenSuse 11.4 for a while but I’ve installed the 64 bit version this time and still have the problem that the ML-1665 won’t print in landscape so I’m guessing that the problem is 64 bit related. I have tried adjusting all of the settings in YaST and in the unified driver to no avail, it even says “landscape” in the printer dialogue but still prints in portrait. I won’t be buying a Samsung printer again in the future :wink:

This has nothing to do with 64-bit IMO.

Did you try the removal of the “excess” driver complements as described in the posts I linked to?

I’m quite sure that your settings in the SAMSUNG printer dialog (not KDE’s or LO’s) is specifying portrait, hence your problem.

As a workaround, you can try printing to PDF from LO (which will rotate the page accordingly), open the PDF in OKULAR and print.

And yes, you can have all the printer’s functionality after some tinkering, (something I didn’t have with an HP Laserjet P1005 under 11.3), but HP lasers are generally better integrated with linux via hplip.

If you mean did I remove these:

:/usr/lib/cups/filter> ls -l rastertosamsung*
-rwxr-xr-x 1 root root 52824 Set 4 2009 rastertosamsunginkjet
-rwxr-xr-x 1 root root 32752 Set 4 2009 rastertosamsungpcl
-rwxr-xr-x 1 root root 56720 Set 4 2009 rastertosamsungspl
-rwxr-xr-x 1 root root 147504 Set 4 2009 rastertosamsungsplc

then yes, I did. But I don’t have the following folder:


I have lots of other manufacturers but no Samsung!

I removed the “excess” files listed above and now the printer won’t print anything at all :frowning:

If this problem is not 64 bit related then why did the printer print in portrait and landscape when I ran OpenSuse 11.4 32 bit on the same machine just two weeks ago using exactly the same driver and settings? It is only since I changed to the 64 bit version that the printer won’t print in landscape. Under OpenSuse 11.4 32 bit I didn’t have to “tinker” with anything to get perfect printing results every time.

I don’t really want to have to export my Oo spreadsheet to PDF every morning in order to print off my list of customers for the day. I know that the ML-1665 used to work fine before without messing about I’m just confused as to why it now doesn’t even though I’ve set everything up like before.

Every setting that I can find whether Samsung or KDE is set to landscape, and the Oo file printer settings are also set to landscape but still the printer prints in portrait :frowning:

Really appreciate all your time and effort brunomci :slight_smile: Many thanks

Well, I’m running it under 11.4 64-bit without issues. that’s why. Do go trough the thread I gave the link for, it was a work-in-progress - first getting the d*mn thing printing, then solving the twice-run packages, then removing the excess cruft, then making it cups-standard (if the samsung folder is not there you only need to create it), etc. a PITA.

I’m not sure what your problem is, here it works OK. Perhaps there is a missing 32bit-compat dependency? Newly installed OSes don’t have much of these packages, it may be worth to check the driver requirements, if any, although I don’t remember needing any.

Can you print a landscape document from a native kde app, like okular? If so, it’s an issue specific to LO (and probably firefox, etc.).

Well, I’m running it under 11.4 64-bit without issues. that’s why.

Fair point :wink:

I tried printing in landscape from Okular which also printed in portrait so I re-installed Oo which changed nothing either so I re-installed Suse and the first thing I did once I had my fresh 64 bit installation was to install the unified Linux driver for the ML-1665 and low and behold I could print in landscape!

Excellent I thought, and continued to install the Nvidia drivers and generally update the system. Once I had run the online update in YaST the Oo icon on my desktop changed and suddenly I’m back to printing everything in portrait … I give up :frowning:

So it would seem that I’m stuck in portrait for a little while, at least until 12.1 has settled enough for me to upgrade to that and then I’ll see if I have the same problem again.

Thanks so much brunomcl for all your help :slight_smile:

Hi All,

Samsung ML-1665 Updated version software and driver link.

Samsung ML-1665 Driver | Samsung Driver Downloads

Hope this help…