Samsung Chromebook ARM web browsing

Konqueror running on openSUSE 12.3 on $249 Samsung Chromebook ARM using instructions at

SUSE Paste

Can you give a better problem description please?

There has been recent activity promoting Chrubuntu for the Samsung ARM Chromebook and virtually no mention of openSUSE as an alternative. The HCL article mentioned gives no indication of web use. I thought an image of graphical web access might encourage more openSUSE use for ARM. But if it is of no interest please delete it. There is no associated problem to be solved.

Well, then we have non-problem forums like General Chit-chat. You posted in the “Get Technical Help Here” part of the forums in the Applications section where it says: “Questions about …”. Rather clear to me about what should go there.

When you want to inform the members here about something good you found, that is of course fine and appreciated, but putting it (or anything else what that matters) in a place where people do not expect it, will not help in getting any message through to the right audience.

Do you want me to move this thread to General Chit-chat?

Yes please move it and thanks for the logical explanation.

CLOSED. Will be moved to General Chit-chat.

Moved from Aplications and open again.

Thank you for reporting that openSUSE works for you on these type of devices.

Spreading the word about openSUSE’s capabilities is oone of the many ways to support it.

This is great, ionmich. Indeed not much attention is drawn to openSUSE’s ARM releases, but IMHO it’s very important. It will bring us Plasma Active on devices etc. ARM is not going away, it’s here to stay.

About OpenSuse on Samsung ARM Chromebook:
Yesterday I installed it. A very simple action. But…
No mail and no websurfer. So I searched for a Software Center to install Firefox and Thunderbird. And found Instellingen → Install/Remove Software. It starts and then I get this message: "UI Syntax error. Couldn’t load plug-in gtk-pkg. Check the logfile "
Here is that log

How do I solve this problem?
By the way: I tried a lot of installations on this Chromebook: Ubuntu, Kali, Bodhi, LAMP, Fedora, Linuxmint, ARCHLinux. And most of them are incomplete or did not work at all. Until now, this is the best. So far…


Whilst this is not exactly a “fix” per se, you could try installing things from the terminal as a temporary workaround:

Open any terminal (gnome-terminal in your case?) and type;**

sudo zypper in MozillaFirefox MozillaThunderbird**
Then try**
sudo zypper ref
sudo zypper up

**to see if there are any updates to the system.

Repost, please ignore :slight_smile:

Indeed, no result:

Next, please? rotfl!

That would indicate that the network or the DNS is not working properly.

You could try pinging Google’s public DNS servers by typing:
in a terminal.

If the result is something like this:
64 bytes from icmp_seq=1 ttl=49 time=20.6 ms

It means it can ping and the network works properly. In that case the DNS server isn’t working. If it cannot ping at all, the network is not properly configured.

Hello Miuku,
Thanks for your quick reply.
It results in repeating lines, such as:

64 bytes from icmp_seq= 240 ttl=50 time=19,8 ms
64 bytes from icmp_seq= 241 ttl=51 time=20,4 ms
64 bytes from icmp_seq= 242 ttl=51 time=21,1 ms
64 bytes from icmp_seq= 243 ttl=50 time=19,6 ms
64 bytes from icmp_seq= 244 ttl=50 time=23,3 ms
, etcetera etcetera.

So I have to wait, if I understand it :(:(:frowning:


Right then, type this;


sudo echo nameserver >> /etc/resolv.conf

This command will add the Google DNS as your nameserver and should allow you to install software normally. For some reason the network seems to have been configured normally but the nameserver isn’t working.

You can also use the YAST / Network Devices / Network Settings to configure the nameserver if you prefer to use a mouse / touch UI.

Yes!! Updating works now, now downloading 174 updates.

Does still not know Thunderbird and Firefox, but after this I will try that.

Thanks so far.


You should now be able to use the YAST graphical software management and no longer need to use the terminal.

Remember to reboot after you’ve installed all patches!

After having seen 190 updates, I rebooted and went again to the Yast Software Management. But unfortunately I got still the same message:
“**UI Syntax error. Couldn’t load plug-in gtk-pkg. Check the logfile **” And a logfile as shown before.

And however I programmed a lot in my life -I’m now 75 and started about 35 years ago with Basic ,Ms-Access/VBA etc - I’m what they sometimes names a noob in Linux. So please can you tell me how to find a solution for this?


This should most likely be opened as a new thread for support, it seems yast is somehow damaged - your network however now works properly :slight_smile:

Did any of the packages during installation fail or show error messages?

You could try installing Chromium by the way, with sudo zypper in chromium or Firefox with sudo zypper in firefox (from a terminal)

You should at least be able to browse with it then.