Samsung auto-run script drivers for C410W SEE printer

Hello fellow members, I’m new to openSUSE per-se, currently using 13.2 KDE and LMDE 2 on my twin SSD rig.
I have hit a snag trying to install the rerquired print drivers (auto-run script), from a tar.gz file, I downloaded from Samsung for my C410W SEE printer.
On my other OS’s and other computers I usually open the download file with a terminal. Either through “su” or “sudo”.

  1. type this script, “./” then press enter
  2. agree to the license terms y or n
  3. set freewall y or n
  4. job done

For some reason, it will not install properly or stops before the license agreement. Closing the terminal after 10 mins, it informs that a process is still running.
I then do an un-install, and I’ve checked all setings, the system will allow me prior to installing. Even tried from the root account. No joy.

Thank you in advance for much needed help.

Not sure I can help as I don’t have presently have a Samsung printer. But, first make certain the script is marked for permissions “executable”, I have had this problem with scripts in the past.

Secondly, I usually install my printers via cups without the install file. The main problem is finding a ppd file that will work. I try the common emulations if the actual printer is not in the CUPS dialog, (such as generic hp drivers) or alternatively, some other printer from the same manufacturer. Also, I have best luck with gutenprint drivers when printing pdf files, so I will often make at least an alternative printer that uses the nearest model gutenprint driver (since they are not always available for the most recent models.) Also, if you search around on the internet, you may be able to find the ppd file, or copy it from another computer, since the install script will (among other things) install the ppd file.

Thirdly, I have found socket://[IP]:9600 works on most printers and alternatively, lpd://[IP]/print_queue. I’m not certain there is a required print queue name, my brother computers use binary_p1, but that may be an arbitrary name. Socket is supposed to be “raw feed” and often works with or without the port 9600, I think 9600 is the default in any event.

This has worked with a lot of printers.

Strange. I’m using openSUSE 13.1, but in an effort to assist I’ve just downloaded the Universal driver from here

and then proceeded to launch the installer with

sudo /path/to/

I get the license info, press ‘q’ to clear the terminal window, then ‘y’ to agree, and it proceeds with the install just fine. I can’t test further since I don’t actually own Samsung hardware.

Thank you, though your script, produce “bash sudo /path/to/ not found”.

I retried sudo ./ and this time worked, I’m flummoxed, like you said, strange. Cheers for the assist :slight_smile:

How do I mark this as SOLVED.

Well, obviously you have to substitute this for the real path to match where is actually located. :slight_smile:

Anyway, good to know that you managed to complete the install successfully.

How do I mark this as SOLVED.

We don’t tend to do that here - although you can edit your title if you wish.

The Samsung universal driver needs to be installed via the script. It is not as simple as just locating the PPD file using that.