SAMBA?

I looked at the WIKI and the Articles and didn’t see any thing on SAMBA.
I’ll admit to wildly doing stuff in YAST2 to try and get the Folders I want shared read only to appear to a Windows 7 machine.
I can see the shared directories on the Windows 7 machine now but it’s asking for a user name and a password when I try and access the directories.
I set the password up but I see no place for setting user names to permit access in YAST.
How do I get make the list of allowed user names/password combinations on this machine so I can serve up files to the Windows machine?

NFS is so much simpler and less retarded. I need access from the windows machine to this one.

So, not the exact answer you requested, but have a look at my blog post on SWAT here: Samba S.W.A.T. - Samba Web Administration Tool Setup for openSUSE - Blogs - openSUSE Forums

I would also point you to swerdna’s site, one of our Moderators, but it seems to be down tonight for some reason.

Thank You,

jdmcdaniel3 since that article is not the place to post a reply. Isn’t there and easier way then at the stuff at the URL you provided? An existing tool in YAST? What is the tool I used in YAST for? There seems to be no openSUSE resources devoted to that in the WiKi or the articles section I looked at. Am I even posting in the right part of the forum?

All I want to do is serve up read only media files to one Windows box that now has to be left on all the time doing some hams stuff so it can also serve those media files to my iPAd using Air Play while it’s sucking down electricty. Windows 7 asking for a user name and password to access the files on the openSUSE 12.1 machine. Where in openSUSE do I configure them so the Window ‘user’ can connect to the directories that user can already see but not access? I wants a user name and password.

First off, you can post a comment to the blog, but since it was given here, that is just fine. In my Blog I list in detail, all of the steps you need to take which is not difficult that works like a champ. It costs nothing more than anything else one can do, but it is tested every time I load up a PC. It works great between both openSUSE users and Windows users. You ask for a solution and I give you one. Just try it on one openSUSE computer. Give the network time (several minutes) to see the new SMB client and see what you can do. You should at first be able to browse your own shares and if not, something is wrong. Where else can you get such advice for free?

Thank You,

Just getting ready to edit the files. But before I do.

Is S.W.A. T. part of another program/service? I got no hits in the software manager on it in 12.1.
Do I need to stop smb before editing the files?

Two more quick questions. Since this is Windows 7 I don’t need to enable the winbind? Also the firewall is off. Everything is behind an firewall appliance so I can of course omit that step?

I am not seeing the service winbind in System Services (runlevel) on the menu. I am thinking I must need to enable it in YAST?
Windows is still asking for a user name and password and I am thinking that is the reason?

So SWAT is an HTML client who’s port is supported by the xinetd service in conjunction with the swat service file. I am not the expert on its internal workings, but you can find out more from this link:

Chapter 37: SWAT

As for winbind, its not required unless you have a Windows Domain and want to use its users in Samba, so don’t load or turn it on. I give instructions on how to set your firewall and it should not be turned off to use Samba, but what ever you wish to do. Since I give complete instructions, follow my guide first, before you confuse yourself with more details from the link I provided.

Thank You,

Well I am trying to follow in my attention deficited kind of way.
I have followed all the steps down to creating the Desktop Icons exactly but Google Chrome my default browser doesn’t know what to make of them so I deleted them. I am also not quite sure where to create the files? I can open the SWAT browser up the via URL though. Somewhere in my home folder there is a file named ~/Desktop/SWAT I can’t locate even assuring I have hidden files viewable.

I still am being asked for a user name and password when I try and open the directory folders on the Windows 7 machine.

http://www.slhess.com/pictures/password.png

  1. The smb icon is loading dolphin and you can do a Alt-F2 and enter: dolphin smb://windowsnt/, where the name windowsnt is replaced with your workgroup’s name.
  2. I had no trouble using the URL: http://localhost:901 in chrome
  3. In the KDE desktop, SMB is a text file with the folder/name /home/username/Desktop/SMB that reads (You replace windowsnt with the name of your workgroup):
[Desktop Entry]
Icon=network-workgroup
Type=Link
URL$e]=smb://**windowsnt**/
X-SuSE-translate=true

  1. In the KDE desktop, SWAT is a text file with the folder/name /home/username/Desktop/SWAT that reads:
[Desktop Entry]
Icon=yast-samba-client
Type=Link
URL$e]=http://localhost:901
X-SuSE-translate=true

Thank You,

Thanks James

Both files were created and are working. I didn’t have to make them executable they just worked. The second link the SWAT link demands a password? Where are these passwords kept and how did they get set up? Where are these user names being demanded coming from? I don’t want them. I want no passwords and no user names. Is that even possible? Click on icon open directory access files just like they are on your desktop is that possible?

(edit) Now the SWAT icon works. Go figure. I did nothing.

http://www.slhess.com/pictures/password2.png

I was mistaken SWAT is still demanding a username and password to access it so I can’t access it.

I am confusing myself. SWAT is working. The SMB icon is not allowing access to folders either from the local desktop SMB or still remotely.

http://www.slhess.com/pictures/password3.png

I still have no idea where these user names and passwords are supposed to be coming from. Skimming through what I can I see nothing about where and when they are created. I though the setup I used bypassed them.

NFS just works. SAMBA is hosed in comparison.

On 2012-03-15 05:16, FlameBait wrote:

> I still have no idea where these user names and passwords are supposed
> to be coming from. Skimming through what I can I see nothing about where
> and when they are created. I though the setup I used bypassed them.

You personally have to create those usernames and password. You are the
administrator, it is your job >:-)

> NFS just works. SAMBA is hosed in comparison.

Good, tell that to Microsoft, maybe you can convince them. Hold on, M$7
does have NFS…


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

On 2012-03-15 03:26, FlameBait wrote:
>
> I am not seeing the service winbind in System Services (runlevel) on the
> menu. I am thinking I must need to enable it in YAST?

Are you creating a Windows Domain?
If you don’t know, the answer is “No”, so forget winbind.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

On 2012-03-15 00:56, FlameBait wrote:
>
> I looked at the WIKI and the Articles and didn’t see any thing on
> SAMBA.

Look at the book.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Carlos twice you have replied “look at the Book” and on the third time finally provided a URL to it.

NFS only works in Windows 7 if you have Windows 7 Ultimate. I can’t afford to upgrade. I’ll have to make do with SAMBA. I am a private person with limited means this isn’t my job or involved in my job. I can’t afford it.

No where in YAST or anyplace else I looked so far did it say how or where to create these undesired user names and passwords.

I haven’t even found how to restart the service to test changes Iv’e made to samba.conf yet.

This one requires the root user name and root user password and is local to administer SWAT.

Thank You,

Well James I got it going before I checked my email so I didn’t see you had posted. Editing my smb.conf file and restarting smb. I was able to stream to my iPad from the Linux box via Air Play when I just tested it (which also had to do a conversion for the iPad format and codec.)

Guests must be allowed and security must be set to share to do as I wanted.


security = share

No password required with the following code for each shared resource.


guest ok =Yes

my conf file.


 # smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2012-02-16
[global]
	workgroup = kitfox
	passdb backend = tdbsam
	printing = cups
	printcap name = cups
	printcap cache time = 750
	cups options = raw
	map to guest = Bad User
        include = /etc/samba/dhcp.conf
	logon path = \\%L\profiles\.msprofile
	logon home = \\%L\%U\.9xprofile
	logon drive = P:
	usershare allow guests = Yes
	add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
	domain logons = Yes
	domain master = Yes
	local master = Yes
	os level = 65
	preferred master = Yes
	security = share
	wins support = No
	usershare max shares = 100

[users]
	comment = All users
	path = /home
	read only = Yes
	inherit acls = Yes
	veto files = /aquota.user/groups/shares/

[Music]
	comment = Music
	inherit acls = Yes
	path = /home/flamebait/Music
	guest ok = Yes
	read only = Yes

[NewPlace]
	comment = NewPlace
	inherit acls = Yes
	path = /Four/NewPlace
	guest ok = Yes
	read only = Yes

[ReallyBigPlace]
	comment = reallybigplace
	inherit acls = Yes
	path = /moreAnime/reallybigplace
	guest ok =Yes
	read only = Yes

[adata]
	comment = adata
	inherit acls = Yes
	path = /data/adata
	guest ok = Yes
	read only = Yes

[asusAnime]
	comment = asusAnime
	inherit acls = Yes
	path = /home/flamebait/asusAnime
	guest ok = Yes
	read only = Yes

[mmshare]
	comment = mmshare
	inherit acls = Yes
	path = /mmshare/mmshare
	guest ok = Yes
	read only = Yes

I edited it and restarted at a super user prompt with


/sbin/service smb restart