Samba Woes

I have a single Opensuse machine which I intend to use as a Home Server. Attached to the same network are a Windows 7 desktop, a Windows 8 desktop and a Windows 7 laptop. Using Swerdna’s Blog Post I have modified my Samba file and got the network up and working. I can browse and use files in both directions and everything is fine… sort of. My wife’s machine can see the server even though the server can see and interact with her machine. I suspect this is a Windows matter and the machine in question is a Samsung which I gather have had problems but I wanted to make sure it wasn’t my Samba configuration before I start messing with Windows.

My smb.conf file is below Could anyone tell me if it is configured correctly, please? I know there are various options opened up and that I ought to only have some open and usable but this is more in the nature of experimenting to find the best way to configure the server.

smb.conf is the main Samba configuration file. You find a full commented# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the

samba-doc package is installed.

workgroup = WORKGROUP
netbios name = Lagavulin
name resolve order = bcast host lmhosts wins
passdb backend = tdbsam
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
#logon path = \%L\profiles.msprofile
#logon home = \%L%U.9xprofile

logon drive = P:

  usershare allow guests = Yes

comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

Share disabled by YaST


Thanks for any help.

The samba config looks good. Especially the netbios name, love that smoky flavour. But there are a few suggestions:

The [groups] stanza is there as an example. The directory /…/groups doesn’t exist. I always delete that stanza from smb.conf because it will confuse the issue. In your case delete it twice because you’ve duplicated it.

If you care to describe what sort of “share” you’d like to have on the Server, I could advise you.

Regarding your wife’s machine, you said: “My wife’s machine can see the server even though the server can see and interact with her machine.” That says to me that all is well. So I’m puzzled. Is there a typo in there somewhere?

I have a blog post with a bash script for working with Samba in openSUSE you might find useful here: S.A.C.T. - Samba Automated Configuration Tool - Version 1.06 - Blogs - openSUSE Forums

Thank You,

Hello, as a sidestep from your problem, please you CODE tags and not QUOTE tags next time when you post compter text like your SAMBA config above. It is the # button in the toolbar of the post editor.

Thanks for the replies, folks. To reply in reverse -

  • Ah, I was looking for a code tag, hcvv, specifically as I have seen on other forums, a button marked code. I’ll know better another time.
  • Thanks for the link to the scripts. They may yet be helpful but I am working on trying to understand what I am doing with this apparently simple text file which I think is fairly near right.
  • Right, swerdna, I have a typo. The way it is that whilst I can access my wife’s machine from the server, she cannot even see the machine never mind access it.I beginning to think it is a problem with the laptop as I gather Samsung ‘customise’ stuff sometimes. I see what you mean about the repeated stanza which I’ll delete but I have got the folder /home/groups so it does work. (Oh and thanks for your tutorials which I am working through!)

If you know how to open up a terminal window, copy text from a forum message here within a code # field, paste that text into terminal session and press the enter key, you can download and run a bash script already written for you and ready to go. KDE icons on your desktop are directly supported:

rm ~/bin/sact ; wget -nc -O ~/bin/sact ; chmod +x ~/bin/sact ; sact

Thank You,

Try two things:

  1. Check that the workgroup name of your wife’s computer is WORKGROUP, like the Linux server
  2. Make the networking of her computer a bit like netbios styles as in this tutorial: Setup Windows 7 to Share Resources on an openSUSE Samba Network

An aside: you’ve got this in smb.conf: inherit acls = Yes
Take the square bracket “” off the end

Tha’s it for now