samba, windows finds my shares but linux does not

I can’t for the life of me figure out why I cannot browse my own shares from my linux boxes.
both run OpenSuSE 11.3
I follow swerdna’s tutorials and reboot several times but don’t have a clue as to whats going on to prevent me from viewing localhost shares or 2nd linux box shares.

I get ‘unable to mount location, Failed to retrieve share list from server’ error when I click on my workgroup icon in nautilus.
any help appreciated.

Try turning the firewalls off, just as a temporary diagnostic tool, see if that fixes the situation. (Yast → security & users → firewall → disable auto starting + turn off now)

I couldn’t get Linux to connect to my workgroup until I started from scratch with the samba.conf file. There is a bunch of extra info in the default file, I used swerdna,s guide to re-write it with only what I needed and it worked without having to reboot anything.

This is all I have in mine:

workgroup = BOLLENDORF
netbios nmae = AGAMEMNON
passdb backend = tdbsam
name resolve order = bcast host lmhosts wins
map to guest = Bad User
local master = yes
preferred master = yes
os level = 65
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
load printers = yes
use client driver = yes
server string = “”
usershare allow guests = Yes
usershare max shares = 100
usershare owner only = False

comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0700
guest ok = Yes
browseable = No

path = /home/daniel/Music
read only = no
guest ok = yes
force user = daniel

path = /home/daniel/Videos
read only = no
guest ok = yes
force user = daniel

firewall was off.
restored smb.conf to original (default).
will try the steps again.

went through the steps on swernda’s site and miraculously it now works.
thank you swerdna.

Glad for you (although I think perhaps it was not miraculous lol!)

yeah, it works shares are visible from win machine and linux box but not writable…
even though “read only = no” parameter is set.

If the underlying Liux permissions on the shared folder disallow the guest to have write access, then writing will be disabled despite the “read only = no” setting via Samba. Since you are set for guest access, you should set the Linux permissions on the shared folders to drwxrwxrwx. One way to do that is to use the file explorere/browser or alternatively to chmod them to 777 see e.g. here Notes on chown and chmod