Samba username + password

I set up a samba file sharing system but my workgroup asks for a username and password see this-

http://www.rosanacasco.com/smbusr.png

This is the text in /etc/samba/smb.conf:

smb.conf is the main Samba configuration file. You find a full commented

version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the

samba-doc package is installed.

Date: 2009-10-27

[global]
printcap name = cups
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \%L\profiles.msprofile
logon home = \%L%U.9xprofile
logon drive = P:
usershare allow guests = Yes
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain master = No
usershare max shares = 100
passdb backend = smbpasswd
security = user
workgroup = workgroup
domain logons = No
wins support = Yes

[homes]
comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes

[profiles]
comment = Network Profiles Service
path = %H/
store dos attributes = Yes
create mask = 0600
directory mask = 0700

[users]
comment = All users
path = /home/
inherit acls = Yes
veto files = /aquota.user/groups/shares/

[printers]
comment = All Printers
path = /var/tmp/
printable = Yes
create mask = 0600
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers/
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

Share disabled by YaST

[netlogon]

comment = Network Logon Service

path = /var/lib/samba/netlogon/

write list = root

What’s the question?

If you are wondering what password it wants, it’s not your Linux password. While the login name has to be the same as a Linux account, the password is separate and set using the smbpasswd program.

Have you read swerdna’s tutes on Samba? Search for swerdna samba.

The question is how do I get the username + password I used smbpasswd but it did not do anything. This is the thing I wrote.


linux-3sqj:/home/stephen # smbpasswd -a stephen
New SMB password:
Retype new SMB password:
Added user stephen.
linux-3sqj:/home/stephen # pdbedit -L -w
stephen:1000:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:7122B75C7C64CE61FED1F1B808EF5DB1::LCT-4BB27EE6:
linux-3sqj:/home/stephen # /etc/init.d/smb
Usage: /etc/init.d/smb {start|stop|status|try-restart|restart|force-reload|reload|probe}
linux-3sqj:/home/stephen # /etc/init.d/smb restart
Shutting down Samba SMB daemon                                                                                                                        done
Starting Samba SMB daemon                                                                                                                             done
linux-3sqj:/home/stephen # /etc/init.d/nmb restart
Shutting down Samba NMB daemon                                                                                                                        done
Starting Samba NMB daemon                                                                                     
done

It seems not to do anything to use this program. I did read that collection of articles(although not the whole thing I used the article by openSUSE.org) but that’s the only place it got me also did you see the photo?

This is just a problem with the latest version of Samba. You need to drop back to version 3.4.2-1.1.3.1 in Software Management and after the downgrade, lock the older version in place until a newer version that works gets posted. I assume you have Samba version 3.4.3-3.2.1 loaded right now which has the problem.

Thank You,

I can not believe I don’t know how to downgrade a package. There is no option in zypper or yast2 software management. Can you tell me how to do it? It was very easy in yum when I used fedora. I have the same version you just mentioned.

I can’t downgrade samba how do you? I can’t downgrade because I pushed the ratio button in versions for the older version but it didn’t do anything…

It does not work.

It appears based on your last post you were successful in downgrading your Samba version. If you need further, help, please do not hesitate to ask.

Thank You,

Yes, I did but it still is the same.

First off I see no PC Netbios Name in your smb.conf file which names your PC. You should add the line in the [Global] section:

netbios name = pcnamehere

Second, how many computers do you have (you need two or more) to share with and is there workgroup name also call workgroup?

workgroup = workgroup.

If you have three or more computers, do the other two computers share files just fine between themselfs?

Finally, when you are in software Management, are you sure the installed version is 3.4.2-1.1.3.1? I have a small forum post you can read to properly setup Samba at:

Samba SMB file sharing in openSUSE 11.2 - openSUSE Forums

Please look at this write and double check your setup.

Thank You,

Nope. It simply won’t work are you sure you saw the picture? Maybe you are talking about a different password. I want no username or password. Is that possible? I’ll do this later, time to go to bed…

Please have a good rest and come back tomorrow. I think you have two problems.

  1. When you attempt to view a workgroup and it asks for username and password, that is a problem with the updated Samba.

  2. You need to change how your smb.conf is written to have a successful operation using Samba.

When you come back we can have a more detailed discussion on what needs to be done.

Thank You,

@stephenmac7: this should fix the problem for you, at least in terms of the faulty RPMs:

Fixing “Authorization Dialog” bug in Samba for 11.2 - openSUSE Forums

I downgraded samba and samba-client I still get the dialog and it still won’t work even if I put the right password. My firewall accepts samba server and client.

What do you get when you run this command:

rpm -qa | egrep "samba|smbclient|libwb"

I get this:


linux-3sqj:/home/stephen # rpm -qa | egrep "samba|smbclient|libwd"
yast2-samba-server-2.18.2-2.1.noarch
kdebase3-samba-3.5.10-28.6.i586
libsmbclient0-3.4.3-3.2.1.i586
samba-client-3.4.2-1.1.3.1.i586
yast2-samba-client-2.18.3-2.2.noarch
samba-3.4.2-1.1.3.1.i586

That libwd should have been libwb, but never mind that for now.
I’m confused by the presence of kdebase3-samba, do you know why it’s there? But we’ll move on for now.

You have a mix of 3.4.3 and 3.4.2 RPMs. I suggest you upgrade them all to 3.5.1 using this method:
Fixing “Authorization Dialog” bug in Samba for 11.2 - openSUSE Forums
but be careful, that was written from a 64 bit installation, so re-think it for your 32-bit installation.

Thank you that fixed it!

Such a simple problem, and it took 17 posts – oh well, that sometimes happens. Glad it’s working again.