Samba upgraded from 42.3 to 15.0 - Windows PC says password wrong - worked fine in 42.3

All my Linux mount -t cifs work perfectly and I can work with the samba shares no problem

on the windows machines I keep getting request for user and password - I use the same as in the cifs linux commands - but no go.

All is not lost as they are VirtualBox VM and I can use \vboxsvr\sharename to see them but I have some old apps that need the 8.3 names that pure windows\smb connects provide but VirtualBox shares do not…

Any Ideas on to what went wrong - No firewalls on the Windows boxes (they are each on a seperate NAT network).

Since it works in OpenSUSE 15.0 machines all the ports must be right

I do not use Yast - I had to support over 50,000 SUSE 11 machine that are all over the world without yast and zypper so that no updates are added unless by a custom install application - yes they are stuck in a 2011 version.

I got into the shares as guest with no password in windows.

I don’t know why the user and password failed.

On Wed, 08 Aug 2018 21:46:02 +0000, larryr wrote:

> I got into the shares as guest with no password in windows.
>
> I don’t know why the user and password failed.

What happens if you reset the password using smbpasswd?

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

I tried that - no difference - also tried changing the share guest lines from yes to no - no difference - guest ok = yes and guest only = no is the only thing that worked for both linux and windows.

Set your loglevel to 3/5/5 in smb.conf under global.

log level = 3 passdb:5 auth:5

And check /var/log/log.smbd - my guess would be there’s a signing/encryption issue as a few things changed between 42.x and 15.x (Samba 4.6->4.7) and SMB1 is gone in case you have that set as an option on your Windows boxes (which you really, really, really shouldn’t)

it is /var/log/samba/log.smbd

There was a new samba rolled out today - I rebooted and it appears whatever they changed it seems to fix the problem.

Yeah sorry about that, was typing the message just before going to bed.

Anyway there was a fix for NTLMSSP/NTLM issues in the updated Samba - did you have the issue with Win10 boxes only?

I had 2 win 10 boxes with the problem. I did not check the win 8.1 boxes as they used vboxsvr shares and not linux smb shares.

They work fine now - tested today.