Samba to WinXP workgroup

If I open dolphin, select Network, it tries to connect then fails with “Could not connect to host for smb://smb-network/”
A Konqueror browse attempt returns “Page not found” message.
Do I need to create a user named “dpf” in the XP machine?
I have created a password for dpf (in the SuSE machine) for dpf using smbpasswd -a dpf

Here is my smbtree:

dpf@dpf:~> smbtree -N
cli_rpc_pipe_open: cli_nt_create failed on pipe \srvsvc to machine PSDCF7BD. Error was ERRSRV - ERRnosupport (Function not supported.)
\PSDCF7BD\P1 PrintServer SMB Printer
\DPF\IPC$ IPC Service ("")
\DPF\print$ Printer Drivers
\DPF\groups All groups
\DPF\users All users
\DPF\profiles Network Profiles Service
\DAD\New80gig (D)
\DAD\C$ Default share
\DAD\ADMIN$ Remote Admin
\DAD\My Pictures
\DAD\Shared Music
\DAD\Linz Hawaii
\DAD\shared video
\DAD\All Users
\DAD\print$ Printer Drivers
\DAD\D$ Default share
\DAD\IPC$ Remote IPC


dpf:/home/dpf # smbclient -L dpf
Enter dpf’s password:
Domain=[DPF] OS=[Unix] Server=[Samba 3.2.4-4.5-2154-SUSE-SL11.0]

Sharename Type Comment

profiles Disk Network Profiles Service
users Disk All users
groups Disk All groups
print$ Disk Printer Drivers
IPC$ IPC IPC Service ("")
dpf Disk Home Directories
Domain=[DPF] OS=[Unix] Server=[Samba 3.2.4-4.5-2154-SUSE-SL11.0]

Server Comment

Workgroup Master



dpf:/home/dpf # cat /etc/samba/smb.conf

smb.conf is the main Samba configuration file. You find a full commented

version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the

samba-doc package is installed.

Date: 2009-06-24

workgroup = @HOMENETWORK
netbios name = dpf
name resolve order = bcast host lmhosts wins
map to guest = Bad User
local master = yes
preferred master = yes
os level = 65
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
load printers = yes
use client driver = yes
server string = “”
usershare allow guests = Yes
usershare max shares = 100
usershare owner only = False
lanman auth = Yes
Client lanman auth = Yes
comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

Share disabled by YaST


dpf:/home/dpf #

Check @swerdna’s place; Linux HOWTOs and Tutorials: Suse Linux 10.0, 10.1 openSUSE 10.2, 10.3, 11.0, 11.1

OK - I can now see the shared folders in the XP machine.
Here’s what I did:

  1. go to YaST>software>online update
  2. set the filter field to SEARCH (default value is PATCHES) and search for Samba updates
  3. select all of the Samba library updates and Nautilus (this installed Nautilus application)
  4. open the Nautilus application and double-click the Network tab in the left vertical banner - then simply drill down to the desired folder in the XP machine

So you’ve fixed it – well done!

I’m curious: Does Dolphin work now – or are you getting good results only in Nautilus? And – which version of openSUSE and which Desktop are you using (11.0 KDE I guess)?

this is an enigma…
it worked last night and not now.
smbtree still gives same results but Nautilus can’t see my Windows shares
dolphin is still “in the tank” so to speak

so I’ll fuss with it some more and advise accordingly …