Samba to Win7 - Help!

Just in case, remove this line:

include = /etc/samba/dhcp.conf

And run this command, report here:

sudo pdbedit -L

this is the result of running the command:
Kokoru:4294967295:Kokoru

i eliminated the line in the smb.conf files

by the way thanks for all the help…im very much learning

This line should be simpler, like with a number like 1000 or 1001, sort of like this:

kokoru:1000:kokoru

and kokoru is lower case (looking at the earlier instances of kokoru). So Remove upper case Kokoru with this:

sudo smbpasswd -x Kokoru

and add lower case kokoru like this:

sudo smbpasswd -a kokoru

and check again with this:

sudo pdbedit -L

see if it’s better?

now it says 1001 but the share is still inaccessible…

Looking back I see a new discrepancy in post #16 of this thread. The command smbtree shows this share on the openSUSE computer:

\\JC-BCKUPSRV\windows7

but the contents of smb.conf show a different name for the share

[Bckups]
comment = Bckup-Srv
path = /Windows7
read only = No
guest ok = yes
force user = kokoru

If that is the share then the command smbtree will show the share as

\\JC-BCKUPSRV\Bckups

and not as

\\JC-BCKUPSRV\windows7

So let’s check a few more things to try to resolve that puzzle.

Please post the results of these commands:

testparm -s
ls -l / | grep ndows

And just for completeness, what do you get from this command:

cat /etc/sysconfig/SuSEfirewall2 | egrep 'FW_CONFIGURATIONS_EXT=|FW_DEV_EXT='

best to copy/paste that into a terminal; too easy to make a typo

To the command testparm -s i got this:
Load smb config files from /etc/samba/smb.conf
Processing section “[Bckups]”
Loaded services file OK.
Server role: ROLE_STANDALONE
[global]
workgroup = JCHOUSEHOLD
map to guest = Bad User
name resolve order = bcast host lmhhost wins
printcap name = cups
usershare allow guests = Yes
usershare max shares = 100
usershare owner only = No
cups options = raw

[Bckups]
comment = Bckup-Srv
path = /Windows7
force user = kokoru
read only = No
guest ok = Yes

To the command ls -l / | grep ndows i get this:
drwxr-xr-x 3 kokoru users 16384 1969-12-31 19:00 Windows7

To the last command i get this:

FW_DEV_EXT=“any eth0”
FW_CONFIGURATIONS_EXT=“netbios-server samba-client samba-server vnc-server xorg-x11-server”

Everything is set perfectly on the Linux machine. I can only think of four possibilities but I’m not hopeful:

  1. perhaps the fat32 drive is not mounting properly
    To test that, run this command which will return the mount properties:
df -Th
  1. perhaps the samba password you’re using when coming from the windows box to the Linux box is wrong
    Try re-creating the password with this command again:
sudo smbpasswd -a kokoru
  1. the puzzle where you get this wrong line:
\\JC-BCKUPSRV\windows7

when running “smbtree -N” is not yet solved
do you still get that line returned when you run the command

smbtree -N

or do you now get

\\JC-BCKUPSRV\Bckups
  1. perhaps there’s a problem in windows 7 settings
    Is the workgroup setting in win7 = JCHOUSEHOLD

1:
Filesystem Type Size Used Avail Use% Mounted on
/dev/sda1 ext4 13G 3.6G 8.6G 30% /
udev tmpfs 1.1G 263k 1.1G 1% /dev
/dev/sda3 ext4 2.2G 190M 1.9G 10% /home
/dev/sdb1 vfat 160G 33k 160G 1% /Windows7

2:
I tried changing the passwd again

3:
JCHOUSEHOLD
\JC-BCKUPSRV Samba 3.4.3-3.3.1-2341-SUSE-SL11.2
cli_start_connection: failed to connect to JC-BCKUPSRV<20> (0.0.0.0). Error NT_STATUS_CONNECTION_REFUSED
\JC JC

4:
Yup they are in the same workgroup and they can see each other because i can access the folder but i cant write to it after some change in the smb.conf it started asking for a passwd…

Ok i just checked a second ago after resetting the passwd and rebooting and i can write to the share!!
Thanks so much for all your help, now to learn about permissions and some security options…

There’s a few words on security options and permissions, various types of shares here: Defining and Using File Shares (Services)

abc20000 wrote:
> Oh ok i wont use root unless necessary.

it is ok to use root as much as you want to…as long as you do it the
correct way…you should never log directly into KDE/Gnome/XFCE or
any other *nix-like graphical user interface desktop environment as root…

doing so 1) opens you up to several different security problems, 2)
too many too easy ways to damage your system no matter how careful
your actions (example: just browsing in your home directory while
logged into KDE/Gnome/etc as root can lock you out later as yourself
due to permissions damage), 3) and, anyway logging into KDE/etc as
root is never required to do any and all administrative duties…

that is, your post above says you won’t “unless necessary” and i’m
saying it is never necessary to log into KDE/Gnome/etc to do any
administrative duties,

so, always log in as yourself, and “become root” by using a root
powered application (like YaST, File Manager Superuser Mode) or using
“su -”, sudo, kdesu, or gnomesu in a terminal to launch whatever tool
is needed (like Kwrite to edit a config file)…read more on all that
here:

http://en.opensuse.org/SDB:Login_as_root
http://docs.kde.org/stable/en/kdebase-runtime/userguide/root.html
http://tinyurl.com/6ry6yd
http://tinyurl.com/ydbwssh


DenverD (Linux Counter 282315)
CAVEAT: http://is.gd/bpoMD
posted via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
2.6.22.19-0.4-default SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio