samba slow to connect when firewall enabled

I have been racking my brain with this one for some time now. I have a samba share setup and when users using windows try and map a drive to it, it works but takes almost 2 min before it connects. If I disable the firewall it takes 4 sec to map the drive.

I have ports 137, 138, 139 and 445 open for samba. Also these particular pcs use novell client, not sure if that has something to do with it??? The pcs are using the ipaddress and not the hostname to map.

Anyone have any ideas?

Can you describe how you allowed the ports and whether you allowed TCP and/or UDP?

Sure. Here are the specific rules I have setup for just samba. Also I am using iptables as my firewall.

-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 137:139 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 445 -j ACCEPT

-A RH-Firewall-1-INPUT -m state --state NEW -m udp -p udp --dport 137:139 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m udp -p udp --dport 445 -j ACCEPT

It works and lets you in on these ports but way to slow.

Also all the other ports I have open in the firewall work as well and there is no slowness. Samba is the only one giving me problems.

Have you tried the SuSEfirewall2 options for Samba?

Yea same result. Is there any known issues when using novell client on windows based pcs and samba. Searched the internet and cant find anything but seems to only happen to the pcs using novell clients.

Very odd…

Yes – strange – unfortunately I haven’t encountered Novell Client. Have you tried the Novell forums?

Just tested a pc without the novell client and one with it. The one without the novell client was able to connect withing 4 sec and the one with the client took almost 2 min. So it is the novell client.

Novell forums then I think

Thanks you guys! Went over to the novell forums and found out that port 524 needed to be open for the novell client.

Slow mapping to samba share when novell client installed - NOVELL FORUMS

Now its works just fine.