Samba shares werden nicht geladen

Ich habe hier ein Netzwerk-Laufwerk (ein iomega Home Media Drive), auf dem verschiede Shares eingerichtet sind. Beim Booten werden diese Shares nicht gemountet. Manchmal bekomme ich die Fehlermeldung

Aug 16 08:31:23 zeus kernel: 1755.460201] CIFS VFS: server 192.168.13.4 of type Samba 3.2.5 returned unexpected error on SMB posix open, disabling posix open support. Check if server update available.
aber nicht immer.
Wenn ich bei laufendem System sudo mount -a eingebe, werden die shares kommentarlos gemountet.
Ich bin mir ziemlich sicher, dass dies seit dem Update auf 11.3 so ist; vorher wurden die Shares während des Bootens gemountet.
In der fstab sehen die Einträge so aus (ein Beispiel):

//192.168.13.4/music /mnt/mp3 cifs user=foo,password=bar,uid=stephan,gid=users

Hat jemand eine Ahnung, warum das nicht schon während des Bootens gemountet wird?

Versuchen Sie, die Option _netdev. Außerdem ermöglichen die CIFS-Helfer-Daemon in Yast -> System -> Runlevel

Hallo zusammen,

Ich vermute, dass manchmal mount beim Booten die Einrichtung des Netzes überholt. Dann ist das Netz noch nicht da und es kommt zum Fehler.

Mit der Option _netdev teilst Du mount mit, dass es sich um ein Netzwerklaufwerk handelt. Dann guckt mount erst nach, ob das Netz schon oben ist und wartet gegebenenfalls.

Das zweite, was Swerdna vorschlägt, ist folgendes:

Permanent Mounts: Setting the smbfs daemon (the CIFS mount helper daemon)

This segment is for permanent mounts. Ignore it for temporary mounts.

OpenSUSE uses a helper daemon for mounting the network share at boot time. The daemon cannot be activated until a cifs mount is configured in the filesystem table, fstab, located at /etc/fstab (you may also use smbfstab). Check the daemon’s status in Yast → System → System Services (Runlevel). Scroll to service smbfs. It must show status Enabled=Yes to facilitate the mount process at boot time. If the status is No, then toggle it on with the Enable button.

If you get a status of Yes* with an asterisk, that’s fine and indicates that the daemon is working but no cifs mounts are currently active. If you attempt to Enable smbfs but get an error message like “smbfs start returned 6 – program is not configured” and the status remains at No, then you don’t have a valid cifs mount configured in fstab (or in smbfstab); first configure a mount before returning to enable the daemon again.

(Samba: HowTo Mount a CIFS Network Share [AKA Map Network Drive] in openSUSE 11 plus FAQs)

Kurz gesagt, Du solltest den Dienst smbfs aktivieren unter Yast->System->Systemdienste (Runlevel). Ansonsten, sofern Du gut genug Englisch kannst, empfehle ich Dir die Lektüre der Site von Swerdna bei Samba-Problemen.

Liebe Grüße

Erik

P.S.: I think we should collect to spend Swerdna some german lessons. :wink:

Hallo,

_netdev habe ich angehängt, das hat aber zunächst mal nichts geholfen.

Den smbfs service habe ich nicht gefunden. Ich habe

  • smb, nicht aktiviert, “Samba SMB/CIFS file and print server”

(aber ich will ja keinen Server einrichten) und

  • cifs, nicht aktiviert, “Import remote SMB/CIFS (MS Windows) file systems”

Sollte es der letztere Dienst sein?

Danke für die Hilfe
Stephan

PS:

In 10.2 the daemon is called smbfs
In 10.3 it is the same daemon but the name is changed from smbfs to cifs

Google sagt:

PS:

In 10.2 Der Dämon heißt smbfs
In 10.3 ist es das gleiche Daemon, aber der Name stammt von smbfs auf cifs verändert

Hallo,

Das Aktivieren cifs service hat geholfen. Ich bekomme zwar immer noch
Aug 16 14:29:12 zeus kernel: 31.658373] CIFS: Unknown mount option _netdev
aber die shares sind da, deshalb Danke!

Hallo zusammen,

Strange. I looked it up in 11.1 on my notebook and there it was called smbfs as you can see at the screen shot. Just the same. Now we know what we are talking about.

Komisch, Ich habe das auf meinem Notebook mit 11.1 nachgeguckt und da hieß er smbfs, wie auf dem Screenshot zu sehen ist. Egal. Jetzt wissen wir, worüber wir reden. :wink:

Liebe Grüße

Erik

Hallo,

Gerne. Aber die Fehlermeldung ist seltsam. Hast Du das so:


//192.168.13.4/music /mnt/mp3 cifs user=foo,password=bar,uid=stephan,gid=users,_netdev

man mount sagt eigentlich unter allgemeine Optionen:

_netdev
The filesystem resides on a device that requires network access (used to prevent the system from attempting to mount these filesystems until the network has been enabled on the system).

Dann sollte das eigentlich auch ohne Fehlermeldung gehen.

Liebe Grüße

Erik

Maybe Swerdna could just post his answers in English. Just my opinion of that.

Understanding/reading a foreign language/not native language/not mother tongue (eine Sprache, die keine"Muttersprache"](http://dict.leo.org/ende?lp=ende&lang=en&searchLoc=0&cmpType=relaxed&sectHdr=on&spellToler=&search=Muttersprache) ist) is in my opinion just easier than writing in it. (Personally I make surely many faults when I am writing English.)

And Google seems not to be able to guess the right form of flexion/flection of verbs (here: imperative second person singular: "Ermöglich!/“Ermögliche” or imperative of the humble form “Ermöglichen Sie!”?).
That is no great news or cause for wondering to me!
Just take a look at the flexion of “ermöglichen”: canoonet - ermöglichen - Wortformen.

Because of that understanding original English may sometimes for Germans easier than understanding Googles or any computers trying to translate complete sentences (e. g.: I often have to retranslate some ‘German’ manuals to English to understand them).

So I think we Germans (or Austrians, Swiss and some Belgians or Dansk …) are grateful for Swerdna’s answers
(I am in general and can personally recall no exception)
but in my opinion it would be easier for all (including Swerdna)
if he would just post his answers in English.
And maybe some people with German as native language would translate them to German if it seems necessary/if it is asked for.

Best Regards/Beste Grüße/Mit besten Grüßen
pistazienfresser

Hallo zusammen,

Hey, that was just a joke. It’s very, very kind of swerdna to try to translate his postings to german using google. I really love it. Also because sometimes the translation is really funny (e. g. samba share = Samba Aktie). And if swerdna (or any other of the team) wants to know something about german I’m here to help. :slight_smile:

Liebe Grüße

Erik

BTW: Swerdna, it’s Erik :wink:

[edit]P.S.: Die lustigste Übersetzung, die ich je gelesen habe: "Wenn Rechner jetzt nicht stiefelt, stiefle Rechner mit Stiefeldiskette.[/edit]

rotfl!
Da hätte allerdings vielleicht (teilweise) dem ‘Übersetzer’ schon die Unterscheidung von Verben und Substantiven weiter geholfen: LEO English-German Dictionary “Boot”

Mir fällt spontan nur der Ausdruck “weiblich” für “female electrical contact” ein, aber das scheint (inzwischen?) als “weibliches Teil” tatsächlich im Deutschen/in der deutschen Elektronikfachsprache verwendet zu werden, siehe:
DE-Wikipedia: "Buchse" (scheint - sofern der Kontext klar ist - auch eher eindeutig zu sein irritiert/belustigt mich aber trotzdem…).

Grüße Euch und wünsche allen gutes Wetter
pistazienfresser (;).S Nitram /;))

So sieht es aus:

//192.168.13.4/music /mnt/mp3 cifs user=foo,password=bar,uid=stephan,gid=users,_netdev

mit copy&paste aus der fstab zitiert. Was macht eigentlich mount.cifs mit Parametern, die es nicht versteht? Gibt es die irgendwie an mount zurück?
Und: sind Laufwerke, die mit mount.cifs gemounted werden, nicht sowieso Netzlaufwerke? Muss man das noch extra angeben?
Stephan

Hallo zusammen,

Eigentlich geht cifs das gar nichts an. :wink: Der Parameter weißt mount an, dass es erst guckt, ob das Netz oben ist, bevor gemountet wird. Da ist cifs eigentlich noch draußen vor. Insofern ist es auch egal, dass cifs das nicht versteht. Ich würde das einfach ignorieren, da das ein korrekter Parameter ist, der für mount allgemein gilt und nicht dateisystemspezifisch ist.

Dein Einwand, warum das nötig ist, kann ich verstehen. Aber da wende Dich vertrauensvoll an die Programmierer, die das so vorgesehen haben. :wink:

Liebe Grüße

Erik

Today I found a new workaround to make the share mount at boot time. It is to create a file /etc/init.d/after.local. Make it ececutable. Put these contents inside:

#! /bin/sh 
mount -a

I have given up translating – someone else can perhaps. Fuller story on my website: Samba: HowTo Mount a CIFS Network Share [AKA Map Network Drive] in openSUSE 11 plus FAQs

This seems to work well.

Pistzienfressers Übersetzungsversuch [Ergänzungen/Alternativübersetzugen in eckigen Klammern]:

"Heute fand ich ein neue provisorische Lösung [Workaround] um Dateifreigaben [Shares] während des Bootens [während des Startvorganges] zu mounten [einzubinden/einzuhängen]. Sie besteht darin, eine Datei [unter] /etc/init.d/after.local anzulegen.
Mach sie ausführbar. Kopier diesen Inhalt hinein:
"

#! /bin/sh 
mount -a

Ich habe es aufgegeben [es] zu übersetzen – vielleicht kann es jemand anders. Die ausführlichere Geschichte auf meiner Webseite: : Samba: HowTo Mount a CIFS Network Share [AKA Map Network Drive] in openSUSE 11 plus FAQs

Dies scheint gut zu funktionieren. "

Und bis jetzt hast du gedacht dass Swerdna ein Nahme ist :wink: ?