SAMBA problems once more


I’ve been trying to set up samba for 2 weeks (on and off) and can’t find my configuration error!
System is a SUSE 11.1 (DVD) KDE4 in a VMWARE, default install (installed only for this tests) with servers and kernel development.
1.) using Swerdna’s tutorial, I found the smbfs is not startable (returning 6: service not configured) (I thought, this daemon starts once per smb client??)
2.) the command
mount.cifs --verbose -o username=SERVERUSER,password=SERVERPASSWORD // /home/steme/Documents/fileserver1
bash: // Datei oder Verzeichnis nicht gefunden
gives file or dir not found.

  • both share “documents” and dir “fileserver1” exists
  • smbpasswd is set
  • firewall is off
  • all commands entered as root
  • smbclient -L shows the share
  • access per Windows or even per dolphin works
  • workgroup of client and server is set to the same name

I also tried it with a completely updated system, same results.

Any other information required / any ideas?

If You have shared the directory “fileshare1”
then the syntax is wrong, try:

mount.cifs --verbose -o username=SERVERUSER,password=SERVERPASSWORD //

Hope it is some help to you.

Ahh, never mind, you syntax seems right now that I’ve taken another look.
So I had few beers… :stuck_out_tongue:

I’ve got a mental note to file a bug on that smbfs problem (won’t start). But that won’t prevent a mount, simply delays the mount during boot up.

You should make the VM machine obtain an IP on the same subnet as your other machines (not – more like 192.168.33.Z or whatever). In my setup I use VMware Server and “bridged” networking. That makes my VM a fully fledged member of the LAN. Then mount.cifs works fine.

Hi swerdna

the delayed smb boot I know, but this is something I can live with.

The mount to is the last of several mount configurations (e.g. 2 bridged VM’s, bridged VM to host, also host-only configurations) I tried (at least THIS should work!!).
The bridged and real IP tests I’ve done in every combination already…
funny thing is, in some other configuration it had worked on the real network (10.3? 11.0? don’t remember, as I thought such simple things always work :slight_smile:

just rechecked:
2vm’s 11.1, kde4 bridged, same subnet, server set up SUSE basic with samba (the history of the client is mixed, but should be irrelevant as it is a basic kernel function and also other clients behave exactly the same):
same result: bash: // Datei oder Verzeichnis nicht gefunden (file or directory not found)

What next? Wait for SUSE 12.5 :frowning: thats way too long, I’d like to make use of my pc a little earlier :wink:
I DON’T WANT to have to return to a windows server!!! :’(

What I don’t know: Is it a mount.cifs or a samba problem? What is the difference between accessing a share via smb:// (dolphin / konqueror), a win client or mount.cifs? Maybe somebody can help me with some background knowledge…

I assumed throughout reading the posyts that mount.cifs works. I usually use mount -t cifs. So I tried your version (i.e. mount.cifs) and got these errors:

improperly formatted UNC name. --verbose does not begin with \ or //
Mounting the DFS root for domain not implemented yet
No ip address specified and hostname not found

Then just by switching to mount -t cifs and dropping the “–verbose” bit, then it worked fine. So I suggest drop the verbose and try this:
mount -t cifs -o username=SERVERUSER,password=SERVERPASSWORD //IP_Address/documents /home/steme/Documents/fileserver1

I still think a real IP address would be required. If I use localhost address it just cracks up.

Same configuration, same result… no success

The mount -t cifs just directly implements the mount.cifs command (afaik), and this I used for the verbose to get more information.

Still it’s interesting, that IPAdress works, but not localhost. This I will keep in mind.

You said:

Still it’s interesting, that IPAdress works
Did the share mount when you used real IP address?

@swerdna: Sorry, I used a misleading expression: in your case the real IP adress worked. I didn’t get it to work.

One other funny thing I encountered today:
I set up another (physical) computer to access the shares with samba, no success.
Then I tried the same physical access via mount -t nfs (nfs server installed parallel to the host’s samba server) and got the same error message!?!
What kind of shielding services could be between mount and the server, but not in the line of a “winXP”/“dolphin smb://” access??

It’s beyond me.

I have the reason for the funny mount-behaviour!

When the mount.cifs transfers the password from console input to the kernel cifs routines, the mount.cifs (also mount.nfs) aborts if the password ends with a SPECIAL CHARACTER (<)! (I’ve not checked for all special characters, or characters in the middle of the password)
Only commas are not allowed according to the man (option delimiters).
Supplying the same username/password by a credentials file (or interactively by password=) works fine.
Seems to be a bug somewhere in the mount routine.
Should be mentioned in man or corrected in the routine!

So far


well discovered

Thanks swerdna :slight_smile:
One more thing fyi regarding the vmnet interfaces for samba:
The vmnet use a full dhcp, but only a truncated DNS (I think).

I set up my host’s DNS server to do the IP’s of my vmnet, and samba works with host only networks, even with localhost.


p.s. once more I fell for the required CR at the end of smbfstab;-)