SAMBA not following symlinks in 13.1 RC2

I installed 13.1 RC2 into a second partition of my 12.3 machine, using the same Samba configuration files (actually created under 12.2). On this machine my downloads and Documents are symlinked into my Home directory from directories on separate partitions (they and their parent directories have permissions of 755). From my Windows 7 machine I can browse my Home directory and its actual subdirectories normally after logging in, but cannot access the symlinked directories, which I could in 12.3.


# Samba config file created using SWAT
# from UNKNOWN (
# Date: 2012/07/31 14:12:35

    workgroup = X
    map to guest = Bad User
    name resolve order = bcast host lmhosts
    unix extensions = No
    printcap name = cups
    add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
    logon path = \\%L\profiles\.msprofile
    logon drive = P:
    logon home = \\%L\%U\.9xprofile
    domain master = No
    cups options = raw
    wide links = Yes
    follow symlinks = Yes
    usershare allow guests = No
    netbios name = LINUX
    wins support = No
    wins server = 

    comment = Home Directories
    valid users = %S, %D%w%S
    read only = No
    inherit acls = Yes
    browseable = No

    comment = Network Profiles Service
    path = %H
    read only = No
    create mask = 0600
    directory mask = 0700
    store dos attributes = Yes

    comment = All users
    path = /home
    read only = No
    inherit acls = Yes
    veto files = /aquota.user/groups/shares/

    comment = All groups
    path = /home/groups
    read only = No
    inherit acls = Yes

    comment = All Printers
    path = /var/tmp
    create mask = 0600
    printable = Yes
    print ok = Yes
    browseable = No

    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin, root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775

openSUSE 13.1 has moved to Samba 4 which may be the issue. I do not use symlinked directories, but explicit folder shares like this:

  path = /Windows
  read only = No
  acl check permissions = No
  inherit acls = Yes
  guest ok = Yes
  profile acls = Yes

Perhaps you could switch? I have bash script that is helpful in setting up Samba you can find here: S.A.C.T. - Samba Automated Configuration Tool - Version 1.06 - Blogs - openSUSE Forums

Thank You,

Explicit shares do work. :slight_smile: I use the symlinks because I usually have two or three distros on my machine, so I keep separate data partitions and link directories into Home for Documents, dotfiles and such…

Looking at the man pages (a novel concept, I know!) I discovered that *wide links *is no longer a global parameter but has to be specified for each share, so adding it to the [users] section fixed it. EDIT; It didn’t really work; I happened to click on a symlinked directory that had an explicit share set up. :frowning:

Thanx for the help!

BTW, I spent my time in Texas in College Station…:wink:

Actually it does indeed work with wide links = yes added to [users]; I guess it took Windows a while to catch up after I restarted smb…

Happy to hear of your success, I would not have guessed placing it in the user section.

Thank You,