samba issue: suse2xp not working


I have 2 computers. One has only XP, and other XP and openSuse 11. File and printer sharing works fine when boath are in XP, but when I am in openSuse than I can see suse shares from my XP computer, but I cant see XP computer from suse.
I mean I was able to see XP computer from suse, but I could not browse it, when I tried to do that it opened XP computer but like empty folder, nothing in it. Then I installed gadmin-samba and it(I) messed up something and now I cant even see my XP computer.

Whenever you get the chance, try this. First, open up “Samba Server” under YaST Control Center. Make sure that your computer is a part of the same workgroup that your Windows computer is assigned to. You can check this under the “Identity” tab. For instance, my Windows computer is assigned to WORKGROUP, and hence, that is what should be in the “Workgroup or Domain Name” field.

Secondly, make yourself the Primary Domain Controller, which is right underneath the workgroup/domain name field. In my configuration, I also have WINS server support. Again, this is within the “Identity” tab. Furthermore, go ahead and designate yourself a NetBIOS name. This can be whatever you want – mine is just my first name.

I was having the same issue as you when it came to browsing Windows shares/folders. They always showed up empty. What seemed to do the trick was messing with the Firewall, which is also in the YaST Control Center. Go ahead and open that up. Once it is open, click on “Allowed Services,” which is in the left panel. Under the “Services Allowed” drop-down menu, scroll all the way down to “Samba Server,” then click “Add.” Once that is done, click on “Broadcast,” which is also in the left panel. Once there, click on “Add.” Scroll up/down in the “Service” drop-down menu until you reach “Samba browsing.” Now click “Add” again. Go back to the main part, click “Next”->“Finish.”

After all this is done, go ahead and logout/reboot. I usually reboot. See if everything works.

Thanks for answering.

I did as you told me. However, I dont have a service called:
Samba browse in firewall, so I disabled firewall for now. Still not working, the same problem…

Also make sure and check your “Windows Domain Membership” in YaST. Make sure that also has the correct workgroup.

When you run the following command, what does it say?

Go into your console and type: “smbtree”, without the quotes. Also, I imagine you know the name of your Windows computer. Issue the following command:

“smbclient -L <name_of_windows_computer>”

What does this return?

Ok this is the situation:

  1. Firewall totally disabled, and after reboot everything works, I can browse the XP computer. But I dont want my firewall to be off.

  2. Firewall enabled, samba service is added to list. Now I can see my XP computer, but cant browse-i get an empty folder.

  3. In cases 1 and 2 the network name was constant: MSHOME.

But now, with firewall back on, I get this output:

	\\MIROSLAV       		Samba 3.2.0rc1-22.1-1795-SUSE-SL11.0
		\\MIROSLAV\miroslav       	Home Directories
		\\MIROSLAV\IPC$           	IPC Service (Samba 3.2.0rc1-22.1-1795-SUSE-SL11.0)
		\\MIROSLAV\home           	miroslavs home folders on suse
		\\MIROSLAV\pdf-printer    	PDF Printer Service
		\\MIROSLAV\pdf-documents  	Converted PDF Documents
etlogon       	Network Logon Service
		\\MIROSLAV\homes          	Home Directories
	\\DARKO          		slave
cli_start_connection: failed to connect to DARKO<20> ( Error NT_STATUS_BAD_NETWORK_NAME
smbclient -L darko
Connection to darko failed (Error NT_STATUS_BAD_NETWORK_NAME)

Bat the name is good…I dont get it

Okay, I am fairly certain that this a firewall issue. Keep your firewall enabled while having Samba service added to your list. Open up your Firewall application, go to “Broadcast.” Once in there, click “Add”. Under “Zone”, it should be ExternalZone. “Network” should be 0/0 (or whatever is the default I presume). Then, under “Service”, choose Samba browsing. Add->Next->Finish. This should do it for you. You also might want to go back to “Samba Server” in YaST and make sure “Open port in firewall” is checked.

Well…what to tell you besides THANKS mate…works like charm…very nice…

Glad it worked out! Take care.


Great instructions! Worked wonders for me! Thanks!


No problem. I was frustrated much like you probably were, so I figured I’d be of some help. It’s the least I can do.

Well, I haven’t had the same luck. I did a fresh install of Suse 11 and by default when I browse a network folder it comes up empty. :frowning:

I have a NAS drive with a few shared folders and I can’t seem to browse the folders. I did exactly what was suggested here and the same thing happens, empty folders. In previous versions of Suse this worked like a charm. What’s going on now:confused:

Any more suggestions would be greatly appreciated.

Which Desktop Environment are you using?
Which file manager/browser are you using to view the shares?
Does the problem go away if you turn the firewall off?

Suse 11.0 Gnome
Haven’t tried that. Even so, I really don’t want to turn off my firewall.

It works fine here connecting to my local NAS. Do you have the samba
client files installed? Have you run wireshark or tcpdump to see what
is happening? As suggested drop the firewall to test, then re enable it
when finished testing.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 9:56, 2 users, load average: 0.09, 0.09, 0.12
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

On Tue October 21 2008 10:58 pm, Malcolm wrote:


> Hi
> It works fine here connecting to my local NAS. Do you have the samba
> client files installed? Have you run wireshark or tcpdump to see what
> is happening? As suggested drop the firewall to test, then re enable it
> when finished testing.

Look here: for a good HowTo on setting up
Samba. Be sure to check that you have all the ports open on your firewall for
Samba and that you are permitting broadcasts (see above link). However, it
will help you trouble shoot if you can rule out firewall problems. As
mentioned earlier, just drop the firewall while you are testing and restore it
as soon as you are done. Problems like the one you are experiencing could well
be due to a poorly configured firewall.

P. V.
Cogito cogito ergo cogito sum.

Nautilus has a bug in relation to Samba. Please try three things to help me to diagnose whether that is the problem for you.

  1. Turn the firewall of for a short time. See whether the problem goes away. Turn the firewall back on again.
  2. Execute this command in a console and see whether the shares are displayed in the response:
smbtree -N
  1. Type the address of a share into the Nautilus browser like this:

and see whether you see the files inside the share.

Tell us what happened

PS reference: Gnome Bugzilla: Bug 524485 - nautilus does not display samba shares for machines inside an ADS network. (gvfs)

I think this is more than a Nautilus problem, I cannot connect from OpenSuSe 11 running KDE4 to my Samba server with dolphin. If I open dolphin, select Network, it tries to connect then fails with “Could not connect to host for smb://smb-network/”

“smbtree” asks for a password then shows the Samba tree,

“smbtree -N” shows the tree without asking for a password, whilst “smbclient -L <server hostname>” again asks for my password then shows all samba servers, shares etc

But if I open Konqueror, enter “smb://<server name>/<share name>” I am then asked for a username & password and the files are then shown.

I would suggest from this, that whilst I can connect manually, connecting automatically from a program is borked somewhere in the background:(

The Nautilus problem: if it is the version that comes with openSUSE 11.0 then it has the bug mentioned earlier.
The Dolphin problem: which version of openSUSE and which version of Dolphin are you using?

Tried all the above but nothing; the same thing. I like to make a distinguish though. When I try to browse the shares on a WinXP machine I can see the files fine. The problem is on my NAS. There they keep coming blank.

I have a Buffalo LinkStation 250GB. Browsing the files on this NAS with previous versions of Suse (10.3 and below) was no issue.

Please advise…

PS: Now, Ubuntu 8.10 also has the same problem.