Samba doesn't do sym links even when I do what everyone tells me

I can access everything in my home directory, except this sym link that links to a mount point in /mnt. I can access it fine on the host machine but Samba can’t do it.
Googling this I find a pile of advice saying I should do:

[global]
        unix extensions = no
[user]
        follow symlinks = yes
        wide links = yes

and then restart Samba, but it still doesn’t work.

I’m running openSUSE 12.2 64-bit.

smb.conf:


# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2013-08-06
[global]
    workgroup = WORKGROUP
    passdb backend = tdbsam
    printing = cups
    printcap name = cups
    printcap cache time = 750
    cups options = raw
    map to guest = Bad User
    include = /etc/samba/dhcp.conf
    logon path = \\%L\profiles\.msprofile
    logon home = \\%L\%U\.9xprofile
    logon drive = P:
    usershare allow guests = No
    add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
    domain logons = No
    domain master = No
    unix extensions = no
    security = user
    wins support = No
    usershare max shares = 100
    wins server = 

## Share disabled by YaST
# [homes]
#    comment = Home Directories
#    valid users = %S, %D%w%S
#    browseable = No
#    read only = No
#    inherit acls = Yes
[profiles]
    comment = Network Profiles Service
    path = %H
    read only = No
    store dos attributes = Yes
    create mask = 0600
    directory mask = 0700
[users]
    comment = All users
    path = /home
    follow symlinks = yes
    wide links = yes
    read only = No
    inherit acls = Yes
    veto files = /aquota.user/groups/shares/
[groups]
    comment = All groups
    path = /home/groups
    read only = No
    inherit acls = Yes
[printers]
    comment = All Printers
    path = /var/tmp
    printable = Yes
    create mask = 0600
    browseable = No
[print$]
    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775

## Share disabled by YaST
# [netlogon]


So I am not sure it can be fixed or not. I have a bash script that is very helpful working with Samba you can find here:

S.A.C.T. - Samba Automated Configuration Tool - Version 1.06 - Blogs - openSUSE Forums

Thank You,

Add allow** insecure wide links = yes** to [global], restart Samba.
Note: this can be a security issue in some cases.

If this fails, make sure AppArmor isn’t preventing access by running yast2 apparmor and choose update profile and see if it is blocking access to /mnt.

The smb.conf setting didn’t work, but the AppArmor one did. Unfortunately, it only worked for the root directory of the mount, nothing below it. Every time I tried to access another one, it prevented me from going into the directory, so I had to run AppArmour again and “Allow” that one directory. How do I get it to allow the whole tree, or just stop interfering with that mount?