Samba client OpenSuse 11.2

I have a samba server on my LAN. It can be accessed without any problems from Windows machines on the LAN without password.

I have two computers that I have updated to OpenSuse 11.2 (both used to run 10.3).

Since doing this upgrade I can no longer access the samba share from the Suse machines.

Basically, both Dolphin and Konqueror ask for a username and password to access “avoca” (the workgroup).

Is there a simple answer?

Thanks,

John

On Tue April 13 2010 04:06 pm, Avoca wrote:

>
> I have a samba server on my LAN. It can be accessed without any problems
> from Windows machines on the LAN without password.
>
> I have two computers that I have updated to OpenSuse 11.2 (both used to
> run 10.3.
>
> Since doing this upgrade I can no longer access the samba share from
> the Suse machines.
>
> Basically, both Dolphin and Konqueror ask for a username and password
> to access “avoca” (the workgroup).
>
> Is there a simple answer?
>
> Thanks,
>
> John
>
John;

This sounds a lot like the Samba 3.4.3 bug. See the sticky by Swerdna at the
top of this forum.
http://forums.opensuse.org/get-help-here/network-internet/436226-fixing-authorization-dialog-bug-samba-11-2-a.html
The solution is either to upgrade to Samba 3.5.2 or downgrade to 3.4.2 from
the distribution disk. (Note: 3.5.2 was released after Swerdna wrote the
sticky so following that thread will lead you to 3.5.2 rather than 3.5.1)


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

@P.V. FYI I’ve now written the correct versions into the sticky

Updated the Samba client as per your instructions. That seems to have fixed it, almost.

I can now get to the workgroup, click on the server and then see the samba share. It’s called “backup” just as it should be.

If I click on this I get “The process for the smb://server_name protocol died unexpectedly”

Is this another bug in the samba client? Now running 3.5.2-1.1

BTW In addition to samba-client, I also upgraded:
cifs-mount, libldl0, libsmbclient0, libtalloc2, libtdb1, libtevent0 libwbclient0

Thanks,

John

Let’s have a look at all of them, can you run this command (might be as well to use copy/paste):

rpm -qa | egrep "cifs-mount|libldb0|libsmbclient0|libtalloc2|libtdb1|libtevent0|libwbclient0|samba|samba-client"

For what it is worth, I got a similar error until I tried a different approach to updating Samba based on another suggestion in this forum on how to upgrade to KDE 4.4.2. So, you must add the following URL (excluding the quotes) to your YaST>Software Repositories, if you have not already done so and name it Samba:

http://download.opensuse.org/repositories/network:/samba:/STABLE/openSUSE_11.2

After you save your new repository addition, you start the Software Management tool in YaST. Once Started, Select the top left View Button, just below File and select Repositories. In the Repository list, Select Samba. Just to the right of your Repository listing, you see the files that exist in the Samba Repository that you added. Above that list is a line that says “Switch System Packages to the versions in this Repository”. I think it may be in Yellow, if not done before, but blue if done before. Select this option and then press the Select button on the bottom right. By updating Samba in this way, you will make sure ALL required or supplied files in this Repository will be used. I would give this method a try as it worked for me.

Thank You,

libtdb1-3.5.2-1.1.i586
yast2-samba-client-2.18.3-2.2.noarch
yast2-samba-server-2.18.2-2.1.noarch
kdebase3-samba-3.5.10-28.6.i586
libsmbclient0-3.5.2-1.1.i586
samba-client-3.5.2-1.1.i586
libtevent0-3.5.2-1.1.i586
libtalloc2-3.5.2-1.1.i586
libldb0-3.5.2-1.1.i586
cifs-mount-3.5.2-1.1.i586
libwbclient0-3.5.2-1.1.i586

Thanks,

John

I tried this. But nothing happened. I think because it was was all already up to date.

On a hunch, I downgraded everything I could to 3.4.2.

It now works!!! Yabba dabba do!

Just for your information this is what I am now running:-

samba-client-3.4.2-1.1.3.1.i586
yast2-samba-client-2.18.3-2.2.noarch
yast2-samba-server-2.18.2-2.1.noarch
kdebase3-samba-3.5.10-28.6.i586
libtevent0-3.5.2-1.1.i586
libsmbclient0-3.4.2-1.1.3.1.i586
libtalloc2-3.5.2-1.1.i586
libldb0-3.5.2-1.1.i586
libtdb1-3.4.2-1.1.3.1.i586
libwbclient0-3.4.2-1.1.3.1.i586
cifs-mount-3.4.2-1.1.3.1.i586

Thanks for all your replies,

John

All a bit of a puzzle, particularly with “kdebase3-samba” in there and with the main RPM “samba” missing, but hey it’s working and that’s what matters :slight_smile:

Please explain. Is kde3base samba not required?

John

If you’re using KDE3, then it is required, otherwise not. But the mantra is “if it’s working, then it’s working”.