Samba cannot connect to server

Hi, I have 2 openSUSE 12.3 boxes, both with Samba installed and configured. Apart from the different shares the config is identical. With both the Samba server starts happily.

To one I can connect from either box - so the client works on both.

To the other neither client can connect.

Have ensured that the user I am trying connect as has been added (smbpasswd…).

Here is the output of smbclient -d 4 -L localhostlp_load_ex: refreshing parameters
Initialising global parameters
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
params.c:pm_process() - Processing configuration file “/etc/samba/smb.conf”
Processing section “[global]”
doing parameter workgroup = SECONT2
doing parameter passdb backend = tdbsam
doing parameter printing = cups
doing parameter printcap name = cups
doing parameter printcap cache time = 750
doing parameter cups options = raw
doing parameter map to guest = Bad User
doing parameter include = /etc/samba/dhcp.conf
params.c:pm_process() - Processing configuration file “/etc/samba/dhcp.conf”
doing parameter logon path = \%L\profiles.msprofile
doing parameter logon home = \%L%U.9xprofile
doing parameter logon drive = P:
doing parameter usershare allow guests = No
doing parameter add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
doing parameter domain logons = No
doing parameter domain master = No
doing parameter security = user
pm_process() returned Yes
added interface eth0 ip=fe80::eea8:6bff:fef9:71d0%eth0 bcast=fe80::ffff:ffff:ffff:ffff%eth0 netmask=ffff:ffff:ffff:ffff::
added interface eth0 ip=192.168.0.18 bcast=192.168.0.255 netmask=255.255.255.0
Client started (version 3.6.12-59.9.1-3061-SUSE-SL12.3-x86_64).
Enter root’s password:
resolve_lmhosts: Attempting lmhosts lookup for name localhost<0x20>
resolve_lmhosts: Attempting lmhosts lookup for name localhost<0x20>
getlmhostsent: lmhost entry: 127.0.0.1 localhost
Connecting to 127.0.0.1 at port 445
session request ok
Doing spnego session setup (blob length=58)
got OID=1.3.6.1.4.1.311.2.2.10
got principal=NONE
SPNEGO login failed: NT_STATUS_IO_TIMEOUT
session setup failed: SUCCESS - 0

After the bold line it hangs for about 10-20 seconds.

How can I resolve?

Thanks, David.

It would be useful to post the risult of:

cat /etc/samba/smb.conf

Be sure to place** Code # tags** around anything taken from terminal or a copy of your smb.conf file using the advanced message text editor. For help with Samba, have a look at my blog on the subjecy here and even includes a complete system Samba setup script.

S.A.C.T. - Samba Automated Configuration Tool - Version 1.06 - Blogs - openSUSE Forums

Thank You,

smb.conf is the main Samba configuration file. You find a full commented

version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the

samba-doc package is installed.

[global]
workgroup = SECONT2
passdb backend = tdbsam
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \%L\profiles.msprofile
logon home = \%L%U.9xprofile
logon drive = P:
usershare allow guests = No
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain logons = No
domain master = No
security = user

wins server =

wins support = No

[homes]
comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes
[profiles]
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700

Share disabled by YaST

[users]

comment = All users

path = /home

read only = No

inherit acls = Yes

veto files = /aquota.user/groups/shares/

[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes

[printers]
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775

[Movies]
comment = Movies
inherit acls = Yes
path = /run/media/djm/Movies
read only = No

[NexStExt2]
comment = NexStExt2
inherit acls = Yes
path = /run/media/djm/NexStExt2
read only = No

Share disabled by YaST

[netlogon]

This is what I suggested by using code # tags around your smb.conf file, not at the end. I assume you also did not look at my recommended blog post?

Thank You,

I ran your script. All tests passed. But still smbclient -L localhost hangs then fails. Any other suggestions?

By the way I don’t understand what you mean by “# tags”. As you can see below I added the characters “# tags” but it didn’t change the preview appearance.

tags


S.A.C.T. - Samba Automated Configuration Tool - Version 1.20

Terminal Command: /bin/systemctl status nmb.service

nmb.service - LSB: Samba NetBIOS naming service over IP
Loaded: loaded (/etc/init.d/nmb)
Active: active (running) since Tue, 2013-08-20 20:57:52 EST; 7s ago
Process: 18297 ExecStop=/etc/init.d/nmb stop (code=exited, status=0/SUCCESS)
Process: 13623 ExecReload=/etc/init.d/nmb reload (code=exited, status=3)
Process: 18307 ExecStart=/etc/init.d/nmb start (code=exited, status=0/SUCCESS)
CGroup: name=systemd:/system/nmb.service
└ 18316 /usr/sbin/nmbd -D -s /etc/samba/smb.conf

Aug 20 20:57:52 mediacentre.secont.com systemd[1]: Starting LSB: Samba NetBIOS…
Aug 20 20:57:52 mediacentre.secont.com nmb[18307]: Starting Samba NMB daemon …
Aug 20 20:57:52 mediacentre.secont.com systemd[1]: Started LSB: Samba NetBIOS …

Terminal Command: /bin/systemctl status smb.service

smb.service - LSB: Samba SMB/CIFS file and print server
Loaded: loaded (/etc/init.d/smb)
Active: active (running) since Tue, 2013-08-20 20:57:52 EST; 7s ago
Process: 18269 ExecStop=/etc/init.d/smb stop (code=exited, status=0/SUCCESS)
Process: 13633 ExecReload=/etc/init.d/smb reload (code=exited, status=0/SUCCESS)
Process: 18281 ExecStart=/etc/init.d/smb start (code=exited, status=0/SUCCESS)
CGroup: name=systemd:/system/smb.service
├ 18291 /usr/sbin/smbd -D -s /etc/samba/smb.conf
└ 18292 /usr/sbin/smbd -D -s /etc/samba/smb.conf

Aug 20 20:57:52 mediacentre.secont.com systemd[1]: Starting LSB: Samba SMB/CIF…
Aug 20 20:57:52 mediacentre.secont.com smb[18281]: Starting Samba SMB daemon …
Aug 20 20:57:52 mediacentre.secont.com systemd[1]: Started LSB: Samba SMB/CIFS…

tags

smbstatus works

tags


S.A.C.T. - Samba Automated Configuration Tool - Version 1.20

Terminal Command: smbstatus

Samba version 3.6.12-59.9.1-3061-SUSE-SL12.3-x86_64
PID Username Group Machine

Service pid machine Connected at

No locked files

Error Code on Command Exit = 0, 0 = Success

tags

Given for sure that smb and nmb services are enabled and running and all the needed files are already installed, I’d try this slight change in the smb.conf file:

wins support = yes
name resolve order = bcast host lmhosts wins

Thanks for the help and suggestions.

I tried adding the below lines. No change unfortunately.

Here is a guide on using code # tags in the openSUSE forum.

https://forums.opensuse.org/content/33-posting-code-tags-guide.html

Thank You,

Hi, I upped the debug logging on smbclient and compared the results on my working computer to the one where smbclient fails. The first obvious difference is just after entering the password. The one that fails gets:

Running timed event "tevent_req_timedout" 0x7fce08754b80SPNEGO login failed: NT_STATUS_IO_TIMEOUT

Is it meant to be using Kerberos/SPNEGO security? If not how can I turn off?

If I add

client use spnego = yes

to the machine on which I run the client, then it connects fine. But I shouldn’t have to add this to every machine from which I will access the shares. How can I get the server not to expect or cause the client to try SPNEGO?

On 8/21/2013 7:16 AM, djmills wrote:
>
> If I add
>
> Code:
> --------------------
> client use spnego = yes
> --------------------
>
>
> to the machine on which I run the client, then it connects fine. But I
> shouldn’t have to add this to every machine from which I will access the
> shares. How can I get the server not to expect or cause the client to
> try SPNEGO?
>
>
djmills;

The default value for the parameter “client use spnego” is yes. So you do not need to assign a value if you want yes.

See man smb.conf


P.V.
“We’re all in this together, I’m pulling for you” Red Green

None of my recent attempts to post seem to be making it.

Anyway, my last post had a typo. It should have read:—

If I add:

client use spnego = No

to /etc/samba/smb.conf on the client side then I can connect. Without it I cannot. But this only work for my Unix client. For my Android phone there doesn’t seem to be a way of doing this. Is there something I can set on the server side so that no client needs this change but will still connect?