Samba broken after update to 11.4 (64-bits)

After the update, the smb daemon will not start:
jarfx:/etc/init.d # ./smb start
Starting Samba SMB daemon [2011/03/12 09:04:08, 0] lib/fault.c:250(dump_core_setup)
Unable to setup corepath for smbd: Permission denied
[2011/03/12 09:04:08, 0] smbd/server.c:1134(main)
smbd version 3.5.7-1.17.1-2505-SUSE-SL11.4-x86_64 started.
Copyright Andrew Tridgell and the Samba Team 1992-2010
[2011/03/12 09:04:08.069212, 0] passdb/secrets.c:73(secrets_init)
Failed to open /etc/samba/secrets.tdb
[2011/03/12 09:04:08.070086, 0] passdb/secrets.c:73(secrets_init)
Failed to open /etc/samba/secrets.tdb
[2011/03/12 09:04:08.070189, 0] smbd/server.c:1234(main)
ERROR: smbd can not open secrets.tdb

What has changed?

I found the solution here: Íå çàïóñêàåòñÿ samba. ::](

In short: disable corresponded AppArmor politic, or just disable it.

Thanks a bunch. That worked. The Russian forum would not have helped me much. Surely this is a bug.
I saw that in the 11.4 release notes, CIFS is disabled by default, but that has nothing to do with AppArmor.

I ran into the same issue with 11.4 64bit. Thanks alot.

BTW, what is the point of AppArmor? I think it was disabled by default on older opensuse versions.

The AppArmor could also be disabled from the Yast as well… and I don’t know what’s the point of AppArmor as well… :slight_smile:


I believe AppArmour provides a layer of security for the system

It was enabled by default in my 11.3 systems, was never(?) an issue.

It appears this samba issue is a default settings bug
see: Samba

I tried to allow Samba in AppArmor and it shut down my machine. I had to reinstall. I saw a bug somewhere that it is in process of being fixed.

In the meantime I have AppArmor disabled and everything works fine. I also saw something on enabling CIFS in runlevel expert mode, too. And I also set a DNS server address for the LAN card even though I am using DHCP. Sorry, I forgot exactly what I did but somehow my shares “decided” to show up on the 7 machine and I could actually access them. Before all this I was only permitted access to the 7 from 11.4 and could copy and send files.

Needless to say, all the other Samba settings must be correct. There is Swerdna’s primer and other tutorials.

Hye you don’t have to disable Apparmor - keep you security on
Just edit the file:

You can check which file exactly you need to permit
I changed the line:
/etc/samba/smb.conf r,
so now it reads:
/etc/samba/** r,

restart and everything is fine;)

Thanks for that. Now that I have a good image backup software, Image for Linux, I will mess with this setting.

I have stumbled across the major contributor to this issue I believe. It is default settings. I do not believe it has anything to do with AppArmor at all. That was a red herring. This is a fresh install after a 11.3 to 11.4 blew up. (that was a intel firmware issue that casused that, NOT Opensuse!)

Here is how to fix your SMB so it works again.
Go to yast2/Security and users/Security Center and hardening. Scroll through those and you may see some things you want enabled. :slight_smile:
Then go to the bottom and click on Enable extra services in runlevel 5. There you will see all your system services. You will soon see some things that should be running! DOH!!! I enabled my smb and cifs stuff and it is working like a champ now.
If you do not care to go in that way, just click system/system services runlevel and access it there. The other exercise is probabaly worthwhile since you may see some things that you were not aware of. Enjoy.

I found this tutorial which worked. I have not turned Apparmor on yet because I am in the middle of a critical project.

How To Network openSUSE 11.4 And Windows

Incidentally, I avoid upgrading and would rather do a clean install. All my folders are on file ready to pop in. So that leaves the updates, repository goodies, and any programs. Under 1 1/2 hours done.