SAGA conflicts with wxWidgets

Hi! Trying my first steps in openSUSE and stepped into problem.

Some applications like Kicad, SAGA require wxWidgets. If I install libwx_baseu-suse1 (and some others libwx_baseu) from openSUSE-Leap-42.1 then I can run Kicad from electronics repo.

But saga_gui produces following error:

saga_gui: relocation error: /usr/lib64/ symbol _ZTI10wxListBase, version WXU_3.0 not defined in file with link time reference

I have tried to use libwx_baseu from Application:Geo repos but then saga_gui crashes without any error :frowning: and Kicad is not working also.
Some answers are here something about STL. Bruno Friedmann-2 Jun 28, 2016; 6:33pm mentioned that: “And we got the same trouble in Application:Geo with Saga having a need for non stl.” What is STL?

Can somebody please explain, what I must do to run SAGA and Kicad on openSUSE Leap 42.1?

Also tried to compile from sources wxWidgets + SAGA without any success.

Recently moved from Mint to openSuse. No problems with Kicad and SAGA in Mint.

Ok, managed to solve this problem. Maybe will be useful to someone else.

The problem was in wxWidgets libs, which are provided in openSUSE OSS repos.
There are two types of them: with (libwx_baseu-suse1 version 3.0.2-5.11, etc.) and without STL (libwx_baseu-suse-nostl1 version 3.0.2-18.10, etc.) committed by davejplater for Audacity issue. And both are not suitable for SAGA!
The only libs SAGA can work with are in GEO repos (libwx_baseu-suse1 version 3.0.2-1.54 ad etc.). So the solution is to install libwx_baseu-xxx and libwx_gtk2u_xxx from GEO repos and use them only with SAGA (otherwise other wxWidgets based apps will not work, like Kicad). The installation is obvious, just put them into separate folder and use LD_LIBRARY_PATH to load with SAGA.

Complete list of libs for SAGA:

And bash to load saga:

LD_LIBRARY_PATH=~/your path to libs folder/
exec saga_gui

Maybe somebody knows the reason of such wxWidgets + STL issues?