SABnzbd port issue

I’m stuck with trying to run SABnzbd on openSuSE 13.2. Don’t seem to be a lot of posts about this issue so it must be something basic getting by me.
All dependencies, etc. seem fine, and all goes well right up to the point of it starting.
Then it chokes on the port. No matter what port I try to use.

JeepNut@Popeye:~/SABnzbd-0.7.20> python --server localhost:40000

or port 8080 or whatever your preference.
It always throws up the html page error re: the port being unavailable and shows the next incrementally higher port as a suggestion.

I don’t find the server to be running already.
I’ve opened the firewall port 8080 and 40000 at alternate times and no change in behavior.
I’ve dropped the firewall entirely and tried it with no change in behavior.
I’ve tried modifying the port in advance in the /home//.sabnzbd.ini file. Was no help.

It seems to ME that the problem is just that the pkg can’t use ports. …just…
I’m not aware that it needs to be run as SuperUser, so I won’t unless that’s what’s required.
Here’s a snip from the setup log.

2015-01-09 00:54:49,655::INFO::[__init__:335] All processes started
2015-01-09 00:54:49,655::INFO::[SABnzbd:335] Web dir is /home/JeepNut/SABnzbd-0.7.20/interfaces/Plush
2015-01-09 00:54:49,655::INFO::[SABnzbd:335] Web dir is /home/JeepNut/SABnzbd-0.7.20/interfaces/Config
2015-01-09 00:54:49,662::INFO::[SABnzbd:464] _yenc module... found!
2015-01-09 00:54:49,662::INFO::[SABnzbd:472] par2 binary... found (/usr/bin/par2)
2015-01-09 00:54:49,662::INFO::[SABnzbd:480] unrar binary... found (/usr/bin/unrar)
2015-01-09 00:54:49,663::INFO::[SABnzbd:485] unzip binary... found (/usr/bin/unzip)
2015-01-09 00:54:49,663::INFO::[SABnzbd:491] nice binary... found (/usr/bin/nice)
2015-01-09 00:54:49,663::INFO::[SABnzbd:495] ionice binary... found (/usr/bin/ionice)
2015-01-09 00:54:49,663::INFO::[SABnzbd:500] pyOpenSSL... found (True)
2015-01-09 00:54:49,665::INFO::[SABnzbd:1528] Starting web-interface on
2015-01-09 00:54:49,666::INFO::[_cplogging:55] [09/Jan/2015:00:54:49] ENGINE Bus STARTING
2015-01-09 00:54:49,669::INFO::[_cplogging:55] [09/Jan/2015:00:54:49] ENGINE Started monitor thread '_TimeoutMonitor'.
2015-01-09 00:54:49,673::ERROR::[_cplogging:55] [09/Jan/2015:00:54:49] ENGINE Error in HTTP server: shutting down
Traceback (most recent call last):
  File "/home/JeepNut/SABnzbd-0.7.20/cherrypy/process/", line 75, in _start_http_thread
  File "/home/JeepNut/SABnzbd-0.7.20/cherrypy/wsgiserver/", line 1644, in start
    raise socket.error, msg
error: [Errno 99] Cannot assign requested address
etc., etc., etc.

All looks like it’s going along swimmingly until it tries to actually start the web interface.
Bus engine starts, then all shuts down after a few seconds.
Any ideas what I can do to find out what’s blocking this puppy from running?


swap localhost for ie:-
./ -s


Thanks kindly! All appears working now.