Running zypper dup

I’m trying to upgrade from 15.2 to 15.3 over the net. When I wrote a USB stick and booted it, it started to run the update, but told me it needed manual interaction. This proved to be a very long list of complicated multiple choice answers to software I had installed long ago and cannot fully recall. Mostly to resolve multimedia problems. I gave up.

I then booted the existing 15.2 and tried to run

zypper dup

It responded with

# zypper dup
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...


The following 1267 items are locked and will not be changed by any action:
 Available:
  4pane-lang abook-lang accerciser-lang accountsservice-lang adriconf-lang agenda-lang
  aisleriot-lang akonadi-calendar-lang akonadi-calendar-tools-lang akonadi-contact-lang
  akonadi-import-wizard-lang akonadi-mime-lang akonadi-notes-lang akonadi-search-lang
  akonadi-server-lang akregator-lang alacarte-lang alkimia-lang almanah-lang amarok-lang
  amsynth-lang amtk-5-lang aMule-lang analitza-lang anjuta-extras-lang anjuta-lang
  apache-commons-lang apparmor-parser-lang apparmor-utils-lang appeditor-lang
  appstream-glib-lang AppStream-lang aqbanking-lang aria2-lang ark-lang artikulate-lang
  asunder-lang atk-lang atomix-lang atril-lang at-spi2-core-lang audacious-lang
  audacious-plugins-lang audacity-lang audio-recorder-lang avahi-lang avidemux3-qt5-lang
  avidemux-lang backintime-lang baloo5-file-lang baloo5-imports-lang baloo5-kioslaves-lang
  baloo5-tools-lang baloo5-widgets-lang balsa-lang baobab-lang bash-lang bijiben-lang
  bino-lang bison-lang bleachbit-lang blender-lang blinken-lang blobwars-lang
  blueberry-lang bluedevil5-lang blueman-lang blueproximity-lang boinc-client-lang
  boinc-manager-lang bomber-lang bombono-lang bookworm-lang boomaga-lang bovo-lang
  brasero-lang breeze5-style-lang brisk-menu-lang brltty-lang budgie-calendar-applet-lang
  budgie-desktop-lang budgie-haste-applet-lang budgie-screensaver-lang
  budgie-screenshot-applet-lang buzztrax-lang byzanz-lang bzr-lang cairo-clock-lang
  caja-extensions-common-lang caja-extension-terminal-lang caja-lang calcurse-lang
  calendarsupport-lang calligra-lang calligra-plan-lang cantata-lang cantor-lang
  capnet-assist-lang caribou-lang catfish-lang ... and 1167 more items.
 Run 'zypper locks -s' to see the complete list of locked items.
Nothing to do.

Since I went to the trouble of removing and locking a large number of unwanted and unneeded language files, why do I have to unlock them in order to remove and lock them again after the update? By the way I have never understood why so many language files are installed when most users only need two or three. All I want to do is upgrade without having to re-install with its usual complications.

Any suggestions will be appreciated.

I may be me, but I am confused.

When you upgrade from 15.2 to 153. (when it comes out) over the net, you do not need any USB stick to boot from.
You just change the repos so the point to 15.3 instead of 15.2 (or use the --releasever option when your repo definitions are ready for that) and dup.

It was download from this page https://get.opensuse.org/testing/#download, the “Network image” under “Intel or AMD 64-bit desktops, laptops, and servers (x86_64)”

Thus I assume, you did not really upgrade over the net (the method I described above), but tried a fresh installation with the Net installation ISO image.

And yes, the installer tells you that it can not update locked packages to their 15.3 RC equivalent, which should not surprise you because that is where locking is for: leaving as it is.

I am not sure why all the rest is not updated, but I can understand that the people who designed this are afraid that the result will be an inconsistent system. (e.g. try to imagine when a package is split into more packages, or some packeges are repackaged into one package, all things that can happen in a re-packaging due to a new openSUSE version).

And if I may say so, I also have a few packages locked, which I do not like on my system. But that is only a few and I can handle that with easy when I upgrade. You may have your reasons, but I do not understand why you put such an effort in uninstalling and locking of innocent language packs. Or you must really have a lack of disk space.

@ionmich

For future reference, you might want to consider changing the default behavior of zypper so that only required packages, and not recommended, (language packs are all recommends), are installed.

in “/etc/zypp/zypper.conf” find “solver.onlyRequires” and set to “true”. (I don’t recall if that is commented out or set to “false” on a default install).

Be aware though there may be odd cases where you will then need to manually install a recommended package to obtain full or additional functionality of a piece of software, but I find that a small price to pay…

I overthought his during dinner. And re-read your posts above.

This is my reconstruction.
You downloaded the Net-install ISO for openSUSE 15.3 (well, some pre-release version of it). I never used the net-installer, but I assume on the first screen it gives you the option to install, or to upgrade (like the “normal” installation ISO does).
Whatever you choose, after it started asking questions, you decided to break it off. The result: nothing happend to your system and this whole story is thus of no influence at all on what follows. It is only a nice deception.

Then, on the openSUSE 15.2 system, you did a zypper dup. That is a distribution update from 15.2 to 15.2. Apart from the extra message it gave, I am not not surprised that the conclusion is: “nothing to do”.

To me it is unclear why you did that zypper dup. Apart from the fact that you now see a side-effect of your policy to remove and lock so many packages.

I followed you advice to use the --releasever option and it looks like everything is working out. A lot of files downloading. Thank you for the simple solution.

Nice to hear.

I assume:

  • that you checked before if $releasever is in all your repo definitions (it seems to be OK though because you say “it worked”);
  • that you checked you now have a 15.3 system by looking in /etc/os-release;
  • that you will do a last zypper dup (with no --releasever of course) after 15.3 is released officia,l to bring your systen to the real thing;
  • that you will after that use your normal update procedure, that may very upon your whim, but may NOT include zypper dup anymore.

Understood, and to be applied. But there is a new problem. New title.

Not quite. YaST reports the repos are still 15.2. So does /etc/os-release. I will re-read everything you wrote and try again tomorrow. In any case I do appreciate the time you have spent on me.

Well, better then check first if you did everything correct.

The general documentationj is: https://en.opensuse.org/SDB:System_upgrade

Everything is of course worth reading, but in this case scroll down to step 4.

Further down you find “Coomand line” where you will find your zypper --releasever 15.3 ref and later the connected zypper --releasever 15.3 dup. But first comes the blue attention filed wher it says you should check your repos for the presence of the ${treleasever} parameter. When you have this, you will be ready for the future and there will be no need to change the repo definitions to point to the repos of the new version by editing. But you must be sure!

So please check this first And when you say that the system is still 15.2 that means you are not done (and reporting problems as you did already is a bit premature).

You may want to show us what your repo list is and in the same time show if teh ${releasver} is in them. You can this (as root) with:

zypper --releasever FOOBAR lr -d

Well I really messed up! But the good news is that it was not my current working 15.2. It was a full backup on another drive, my experimental HD. Now I think I will play it safe, wait until 15.3 is officially released and start again.I can blame it all on Covid which keeps me at home, bored, and looking for something to occupy my time.Thanks again.

I’ve faced a similar issue as ionmich. Just did zypper --releasever=15.3 ref and zypper --releasever=15.3 dup to upgrade from Leap 15.2 to 15.3. But after reboot everything showed up as Leap 15.2. For me executing zypper --releasever=15.3 install openSUSE-release openSUSE-release-ftp did the job. Now grub and other labels showed up Leap 15.3 instead of 15.2 and also /etc/products.d showed a file Leap.prod containing the correct version info.

Whatever you had before your last action, after replacing all the text files that contain the version name by those of 15.3, all things will report 15.3. But whatever you had will still be whatever you had.