Running out of space no /etc/sysconfig/cron/temp? in editor

I use Linux and prefer SUSE, but I do not, by any way, understand what goes on under the bonnet. So please hold this in mind.

I run two computers with Opensuse13.2, one is a small thin client HP unit that I use to watch free-view TV with using a USB dongle, it is limited in space using a flash drive something like 16 GB.

I got a warning tonight saying it was low on disk space, I have managed to free this up by deleting some files in root that stated with TmpDir, there are also lots of files starting with zypp. I am guessing these are temporary directories and the zypp are files left over from the file management system.

Now in Opensuse 13.1 in the /etc/sysconfig/cron I am sure there was a section that allowed the automatic deletion of temporary files over a certain age. I can not find anything similar in 13.2.

Have I missed something, is it done differently now and have I missed a setting?

Could I add something to remove the above files and any other temp files after a certain age, say 1 or 2 days.

Please help.



Sorry the directories seem to be /tmp and /var/tmp

Even if I delete the files in these directories I gain a few hundred Meg, I had a couple of Gig free when I first installed where is all the space going?


If you did a standard install of oS 13.2, you got BTRFS in / with snapshots enabled, so / will increase in size as snapshots are taken periodically. You can disable them in Yast IINM (I don’t use BTRFS).

OK yes it is Btrfs file system, I am just re-installing again from scratch and going ext4 will see if that creeps up or not, I think that is what I used for 13.1 and did not have any issue. These snap shots are they deleted periodically or always kept, if they are used like a recovery item I can see a point but not if all the snapshots are kept.

My main PC has just been done in 13.2 and that is also Btrfs so will find where the settings are and see what I can change, has 32 Gig free at moment on that machine and i do backups from that onto a NAS.

Got to ask here but what do I need to change to stop this action with the Btrfs, I assume it is in /etc/sysconfig but unsure what exactly to change/disable can any one give suggested entries

Thanks for your help.


Should be a section in Yast to turn it off and do some simple management

Lots of snaps are taken and yes they are trimmed and you can control how often and when and how many but the defaults are pretty aggressive. Recommended root partition is now 40 gig for BTRFS.

For details read here

Thanks for the reply.
In the end I went in to software management and removed anything snapper completely!!!


If you simply removed snapper I’n not at all sure that would free any space that it had used. You should at least remove all snaps before removal

Sorry yes I did that previously with the tool in yast before removing it all, it is at the moment all marked as taboo in the software management tool so it does not re-install.


just to be absolutely double sure

xx:~ #  du -sh /.snapshots/*

Yep you are correct there is the hidden directory with lots of other folders etc and it can not be deleted, something about grubenv folders.

I think I will re-install 13.2 this time making sure no btrfs on this machine and no snapper.

The other thin client machine is just being redone back with 13.1 as I can not get the NVIDIA driver to work with the old video chipset an ATI RS690 but I did with 13.1, so that looks like the most it will go up to, I really only use that machine like a freeview TV and even when I had the repositories for NVIDIA etc it would not install them in 13.2.

Live and learn I guess.


ATI is not a NVIDIA chip it comes from AMD thus it does not use the NVIDIA driver it uses the AMD driver. The NVIDIA driver can not work with an AMD chip

Sorry I appreciate it’s not NVIDIA, but I think of it like it as I tend to get to the link for the ATI stuff from the search of 1 click NVIDIA on the opensuse community, further down the page is the ATI stuff.


Where?? I know of no place where NVIDA and AMD drivers are mixed on the same page. I really think you are installing the wrong driver.


At the top of the page is 1 click for multimedia codecs further down are Nvidia and further down are AMD 1clicks.

I always thought that was what I used.

All I know is that after some fafing around I have 13.1 working and the video working OK, as in the Thin client can have video effects, the TV pictures are not running slower then the audio. Usually after some reboots and online updates. So if it triggers something else to happen, I am still hapy.

The main PC is not an issue, I can add the community repositories for things and away it goes.

As said at the beginning what havens under the bonnet I have no idea.

So how do I remove the .snapper directory when even as root it says no?