Running applications icons are not visible

i am using OpenSuse 11 on my pc and currently facing a problem and not able to see the icons of the currently running applications (like banshee, skype etc ) on the bottom right of my screen (i think we called it task bar in windows).

when i start skype and close its window (not quit/exit) to work on other application, the skype icon does not show in that panel to relaunch or maximize. On accessing it from main menu it shows a message that skype instance is already running.

How can i restore the currently running applications icons on the panel it as it was working fine before.

Check the application settings for an option to minimize to tray or close to tray.

I think I’m having exactly the same problem and I’m also a newbie. :shame:
to be honest, I’ve been trying, but I couldn’t find where or how to change the “application settings for an option to minimize to tray or close to tray”… it seems the right answer to how to restore the icon on the panel at the bottom right of my screen, but, as I indicated, I don’t have a clue where and how to start…

I’ll give you some more background information:

until a few days ago, every time when I closed the Skype window (without quitting or exiting the program) a little icon on the panel at the bottom right of my screen stayed, so it was possible to do a quick launch with the left click of the mouse or to get the Skype menu right clicking on it.
after accidentally deleting this Skype icon on the panel, it never reappeared again.

now, after using Skype, when I close the Skype window, no icon remains, although the application is still running (messages appear, I appear to be “on line” to my contacts, etc.).
on accessing Skype from the main menu I get the message that Skype is already running, so I cannot enter the main menu and I cannot make any phone calls, or at least I have to kill Skype first and re-login.

thanks in advance,

sorry, I forgot:
I’m running my computer on the opensuse 11.1 x86-64 version with KDE desktop

If anyone can help me out… I already tried to remove and reinstall with yast2, but the situation is the same.

thanks again,

You probably did some updating and now the plasma setting are corrupted. This can come from old widgets with old config settings for example. To recreate your desktop do this:
In login screen hit Ctrl-Alt-F1, you’ll see the console with a text based login.
Log in with your username and password.
Now type:
rm ~/.kde4/share/config/plasma*
Hit Ctrl-d to get back to login prompt
Hit Ctrl-Alt-F7 to return to login screen.
Now you have the standard desktop appearance for you KDE4, panel, systray etc. should be there.
Mind, you only removed the plasma-settings, so all application related settings (amarok’s collection etc.) are still there.

I resolved my problem!
I didn’t delete the icon, I just disabled my sys tray widget. :embarrassed:
so, for other newbies like me with the same problem: to resolve I just right clicked with my mouse in the bottom/ right corner and clicked to add the sys tray widget to the panel… done!

thanks a lot, knurpht!

Big cheers to you too. I tried removing and re-adding myself a couple of months ago, didn’t work by then (settings remained in plasma-files). Appearently that’s been solved.

I’d like to add, that it is advized by the KDE developpers to start with a clean .kde(4) on every major version release IF PROBLEMS OCCUR. I used to do that on KDE3, but found out that it’s always the plasma files that cause plasma to crash or behave unexpectedly.