Running a obs build command locally with root privileges

Hi,

I am writing a spec file for the cisco VPN client module. While I will not build this module on OBS, I am interested in building the project locally as root, as the installation requires filesystem access to the sources ( create a dummy header file and modify another header file , see Logical Shift: Cisco VPN Installation ).

I tried running osc build --userootforbuild , but it does not run the build as root.

Any ideas on how I can run the build as root ( or alternatively, build the cisco VPN module as a non-privileged user ) would be appreciated.

Thanks,

Robert

Hi
Just build as a KMP. you need to look at the Makefile and not use the
script.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.9-desktop
up 21:56, 3 users, load average: 0.14, 0.12, 0.08
GPU GeForce 8600 GTS Silent - Driver Version: 285.05.09

Thanks for the reply. I tried to replicate the script since otherwise compilation fails

make -C /usr/src/linux-obj/x86_64/default SUBDIRS=/usr/src/packages/BUILD/vpnclient modules
make[1]: Entering directory `/usr/src/linux-2.6.37.1-1.2-obj/x86_64/default’
make -C …/…/…/linux-2.6.37.1-1.2 O=/usr/src/linux-2.6.37.1-1.2-obj/x86_64/default/. modules
CC [M] /usr/src/packages/BUILD/vpnclient/linuxcniapi.o
/usr/src/packages/BUILD/vpnclient/linuxcniapi.c:14:28: fatal error: linux/autoconf.h: No such file or directory
compilation terminated.

That’s one instance where I would like to be able to create an empty file.

Another error requires that I change in netdevice.h from const struct net_device_ops *netdev_ops to just struct net_device_ops *net_device_ops.

I know that this is a very dirty approach, but it’s the only way I know to build the driver.

Hi
Fix the code via a patch (linuxcniapi.c) so it uses the correct file and
location as it’s now generated/autoconf.h


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.9-desktop
up 22:53, 3 users, load average: 0.00, 0.03, 0.09
GPU GeForce 8600 GTS Silent - Driver Version: 285.05.09

Thanks! I was able to get through the first error . I’ve also found a patch which works for the second error, so this is solved.

Thanks again.