runlevel editor problems

I installed 11.1 and everything was fine for a while. Since a couple of days ago - I think it was after patching the system - various services don’t get started at boot time (i.e. mysql, smpppd, apache). I can start them manually, e.g. through Yast2 or console command, but this is annoying. Even after “correcting” the status of the various services in Yast2 through the run-level-editor, next time I boot the system the same thing happens. Any ideas anywhere out there? Thanks for any help and - regards from Salzburg


Have you checked for any errors in /var/log/messages to indicate if the daemons are attempting to start ?

If they are not then we would need to check the scripts for the runlevel you are at, and make sure they are getting set to start.

so in /etc/init.d/rc.5 can you check that the daemons have a script set to S ?


Tux-IT Open Source - BSD and Linux Solutions

Hello - Good to see somebody is willing to help! I have gone through some literature on the concept of init scripts (I am a kind of “newbie” in the Linux area!). Can’t really make out any funnies in the system log. I do see a number of “killprocess” entries in the boot log, however. I am including the last of the latter as well as the contents of rc5.d. As I think I mentioned originally, I can start all of the processes in question (apache2, mysql, cups, and smpppd) manually.
Here comes (some of the boot-log:
Boot logging started on /dev/tty1(/dev/console) at Sat Jan 24 14:19:19 2009

Master Resource Control: previous runlevel: N, switching to runlevel: 5

TurboPrint daemon started
TP-Daemon Version 2.06-1

Starting HAL daemondone
<notice>killproc: kill(2054,20)
<notice>killproc: kill(2074,1)
<notice>killproc: kill(2054,18)
<notice>killproc: kill(2054,12)
Setting up (localfs) network interfaces:
lo IP address:
IP address:
done eth0 device: Intel Corporation 82801DB PRO/100 VE (CNR) Ethernet Controller (rev 81)
eth0 Starting DHCP4 client.
eth0 IP address:

Starting service kdm<notice>startproc: execve (/usr/bin/kdm)

<notice>startproc: execve (/sbin/rpcbind)

Starting rpcbind done
<notice>checkproc: /usr/bin/kdm 3106
<notice>startproc: execve (/usr/sbin/smpppd) /usr/sbin/smpppd ], LESSKEY=/etc/lesskey.bin NNTPSERVER=news MANPATH=/usr/local/man:/usr/share/man INFODIR=/usr/local/info:/usr/share/info:/usr/info SSH_AGENT_PID=3495 DM_CONTROL=/var/run/xdmctl HOSTNAME=hsdesk XKEYSYMDB=/usr/share/X11/XKeysymDB GPG_AGENT_INFO=/tmp/gpg-ljof2N/S.gpg-agent:3494:1 DESKTOP_STARTUP_ID= TERM=xterm SHELL=/bin/bash HOST=hsdesk XDG_SESSION_COOKIE=6569d80d17bd3a5ee8c684c9493eedd8-1232803178.291629-1237187276 XDM_MANAGED=method=classic HISTSIZE=1000 PROFILEREAD=true KONSOLE_DBUS_SERVICE=:1.27 GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/usr/share/themes//QtCurve/gtk-2.0/gtkrc:/home/rainermusik/.gtkrc-2.0-qtengine:/home/rainermusik/.gtkrc-2.0 GS_LIB=/home/rainermusik/.fonts WINDOWID=39846106 MORE=-sl QTDIR=/usr/lib/qt3 XSESSION_IS_UP=yes LC_ALL=POSIX KDE_FULL_SESSION=true USER=rainermusik JRE_HOME=/usr/lib/jvm/java/jre LS_COLORS=no=00:fi=00:di=01;34:ln=00;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=41;33;01:ex=00;32:.cmd=00;32:.exe=01;;32:.bat=01;32:.btm=01;32:.dll=01;32:.tar=00;31:.tbz=00;31:.tgz=00;31:.rpm=00;31:.deb=00;31:.arj=00;31:.taz=00;31:.lzh=00;31:.lzma=00;;31:.zoo=00;31:.z=00;31:.Z=00;31:.gz=00;31:.bz2=00;31:.tb2=00;31:.tz2=00;31:.tbz2=00;31:.avi=01;35:.bmp=01;35:.fli=01;35:.gif=01;35:.jpg=01;35:.jpeg=01;35:.mng=01;;35:.mpg=01;35:.pcx=01;35:.pbm=01;35:.pgm=01;35:.png=01;35:.ppm=01;35:.tga=01;35:.tif=01;35:.xbm=01;35:.xpm=01;35:.dl=01;;35:.wmv=01;35:.aiff=00;;32:.mid=00;32:.mp3=00;32:.ogg=00;32:.voc=00;32:.wav=00;32: XNLSPATH=/usr/share/X11/nls ENV=/etc/bash.bashrc HOSTTYPE=i386 SSH_AUTH_SOCK=/tmp/ssh-ZkrjR3330/agent.3330 FROM_HEADER= SESSION_MANAGER=local/hsdesk:@/tmp/.ICE-unix/3588,unix/hsdesk:/tmp/.ICE-unix/3588 COLUMNS=95 PAGER=less CSHEDIT=emacs XDG_CONFIG_DIRS=/etc/xdg MINICOM=-c on DESKTOP_SESSION=default PATH=/home/rainermusik/bin:/usr/local/bin:/usr/bin:/sbin:/usr/sbin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/mit/bin:/usr/lib/mit/sbin:/usr/lib/qt3/bin:/opt/kde3/bin MAIL=/var/spool/mail/rainermusik CPU=i686 QT_IM_MODULE=xim JAVA_BINDIR=/usr/lib/jvm/java/bin PWD=/home/rainermusik INPUTRC=/etc/inputrc XMODIFIERS=@im=local JAVA_HOME=/usr/lib/jvm/java KDE_SESSION_UID=1001 LANG=de_DE@euro PYTHONSTARTUP=/etc/pythonstart SDK_HOME=/usr/lib/jvm/java LINES=28 KONSOLE_DBUS_SESSION=/Sessions/14 SSH_ASKPASS=/usr/lib/ssh/x11-ssh-askpass COLORFGBG=15;0 SHLVL=4 HOME=/root JDK_HOME=/usr/lib/jvm/java QT_SYSTEM_DIR=/usr/share/desktop-data KDE_SESSION_VERSION=4 OSTYPE=linux LESS_ADVANCED_PREPROCESSOR=no LANGUAGE=en_US XCURSOR_THEME=Oxygen_White LS_OPTIONS=-A -N --color=tty -T 0 WINDOWMANAGER=/usr/bin/startkde OPERADIR=/usr/share/opera LOGNAME=rainermusik MACHTYPE=i686-suse-linux LESS=-M -I G_FILENAME_ENCODING=@locale,UTF-8,ISO-8859-15,CP1252 CVS_RSH=ssh DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-lN9XHDEFY9,guid=94f8ef374a1860e19ea61e49497b156e XDG_DATA_DIRS=/usr/share:/etc/opt/kde3/share:/opt/kde3/share %s USE_FAM= WINDOWPATH=7 INFOPATH=/usr/local/info:/usr/share/info:/usr/info PROFILEHOME= DISPLAY=:0 QT_PLUGIN_PATH=/home/rainermusik/.kde4/lib/kde4/plugins/:/usr/lib/kde4/plugins/ LADSPA_PATH=/usr/lib/ladspa GTK_IM_MODULE=cedilla XAUTHLOCALHOSTNAME=hsdesk %s %s QT_IM_SWITCHER=imsw-multi G_BROKEN_FILENAMES=1 COLORTERM=1 JAVA_ROOT=/usr/lib/jvm/java XAUTHORITY=/root/.xauthTlu8pe mc=() { . /usr/share/mc/bin/
} _=/sbin/startproc PREVLEVEL=N RUNLEVEL=5 DAEMON=/usr/sbin/smpppd ]
<notice>checkproc: /usr/bin/kdm 3106
<notice>killproc: kill(2054,20)
<notice>killproc: kill(2074,1)
<notice>killproc: kill(2054,18)
<notice>killproc: kill(2054,12)
<notice>killproc: kill(2054,20)
<notice>killproc: kill(2074,1)
<notice>killproc: kill(2054,18)
<notice>killproc: kill(2054,12)
<notice>killproc: kill(2054,20)
<notice>killproc: kill(2074,1)
<notice>killproc: kill(2054,18)
<notice>killproc: kill(2054,12)
<notice>killproc: kill(2054,20)
<notice>killproc: kill(2074,1)
<notice>killproc: kill(2054,18)
<notice>killproc: kill(2054,12)
<notice>killproc: kill(2054,20)
<notice>killproc: kill(2074,1)
<notice>killproc: kill(2054,18)
<notice>killproc: kill(2054,12)
and the entries in /etc/init.d/rc5.d:
K01aaeventd K01sshd S01aaeventd S07network-remotefs
K01apache2 K01stopblktrace S01acpid S07pm-profiler
K01auditd K01SuSEfirewall2_setup S01dbus S07smolt
K01autofs K01tpdaemon S01earlysyslog S07spamd
K01autoyast K01xdm S01fbset S07sshd
K01bluetooth K02acpid S01jexec S09autofs
K01bluetooth-coldplug K02alsasound S01random S09casa_atvd
K01casa_atvd K02avahi-daemon S01SuSEfirewall2_init S09cups
K01cron K02cups S02haldaemon S09earlyxdm
K01java.binfmt_misc K02earlyxdm S02network S09nscd
K01jexec K02fbset S03syslog S09smpppd
K01network-remotefs K02haldaemon S04auditd S09splash
K01nscd K02kbd S04rpcbind S10postfix
K01pm-profiler K02postfix S04splash_early S10xdm
K01random K05nfs S05nfs S11apache2
K01smartd K06rpcbind S06kbd S12autoyast
K01smolt K07syslog S07alsasound S12cron
K01smpppd K08earlysyslog
S07avahi-daemon S12smartd
K01spamd K08network S07bluetooth S13stopblktrace
K01splash K09dbus S07bluetooth-coldplug S13SuSEfirewall2_setup
K01splash_early K09SuSEfirewall2_init S07java.binfmt_misc S13tpdaemon

have you tried (as root from cli)

to list services without cli to see what is really there

chkconfig --list

to manually add the services to the startup

chkconfig apache2 on
chkconfig mysql on
chkconfig cups on
chkconfig smpppd on

I am finding that I like the way openSuse does some of these configs, but old school works faster and better in some isntances. THough I have never had an issue with the services GUI app.

I, too, experienced similar problems. Apache, PostgreSQL, and CUPS would not start at boot.

Using the “chkconfig --list” command I verified that they were supposed to start - they were.

I could find nothing in any of the system logs that indicated that they even tried to start. I figured I’d tackle the PostgreSQL problem first. I examined the contents of the /etc/sysconfig/postgresql file and saw that the “POSTGRES_DATADIR” value was incorrect. I changed it to the correct value and re-booted. However, the behavior didn’t change. I then modified the “POSTGRES_OPTIONS” value to “-d 5” (DEBUG level) and rebooted. Success! I then went back and modified the “POSTGRES_OPTIONS” value to “-d 1” (LOG level) and rebooted to make sure that it still worked (it did).

The odd thing, though, is that once the postgresql daemon started, the others did, too. Very strange. I plan to examine those in greater depth later.

So, long story short (too late!) is check the settings in any configuration files that may be in the /etc/sysconfig directory.

Good luck.