Runlevel 3 1920x1080 Screen Resolution

It’s looking like from the options on the grub CL that the highest I can go is 1280x1020x32bit (…or something close to it)… But it still does not fit my entire screen (23’’ LED) …

…if there is a way to make runlevel 3 1920x1080, please fill me in :-)… I have a Nvidia GTX460

Also, whether or not I can do it, how do I save the settings, so I don’t have to type it in at the bottom of the screen in the boot menu…?

…And here’s a side question… How do I drop back to runlevel 3, when I’m in the x system (GUI) ?

Thanks in advance!!!


Don’t think so as the VESA modes don’t support it… you would need to experiment;
VESA BIOS Extensions - Wikipedia, the free encyclopedia

To add what ever you decide on, you need to edit /boot/grub/menu.lst (that’s a lowercase L is the lst file extension) to add a vga=xxx to the boot options.

You can press ctrl+alt+F1 through to F6 to get to a virtual terminal. ctrl+alt+F7 (or F8) to get back to a GUI Desktop.

Is there a way to drop out of the X system, once in there? To just drop out of it, and revert back to runlevel three in the same terminal?


su -
init 3 && exit

With KMS-enabled drivers, the video mode and display port can now be configured via the ‘video=’ kernel boot parameter. For example


In general:


<conn>: Connector, e.g. DVI-I-1, see your kernel log.
<xres> x <yres>: resolution
M: compute a CVT mode?
R: reduced blanking?
-<bpp>: color depth
@<refresh>: refresh rate
i: interlaced (non-CVT mode)
m: margins?
e: output forced to on
d: output forced to off
D: digital output forced to on (e.g. DVI-I connector)

It is important to disable any “vga=” options in grub boot entries where KMS-enabled drivers are in use

nouveau Wiki - KernelModeSetting*