Run Okular without PulseAudio?

I’m running openSUSE 12.2 with KDE 3.5 on my laptop. When I ran into problems with blocked audio I followed SDB:Pulseaudio - openSUSE to disable/uninstall PulseAudio. This workaround indeed solves my sound issues completely.

The article describes moving some of the remaining libpulse* libs to another folder.
As long as they are hidden, sound is ok but okular fails to start. It complains “unable to find the Okular component” and show an empty window.
If I move the libs back, okular works but sound may fail again if Flash/VLC/etc is in use.

I tried to reinstall okular after PulseAudio has been removed, but that didn’t help. Is there a way to make okular run w/o PulseAudio?
Why does okular require audio at all? For reading my PDFs aloud…?

So, I see the following items are required for Okular:

Prerequires:
/sbin/ldconfig
Requires:
libc.so.6()(64bit)
libc.so.6(GLIBC_2.2.5)(64bit)
libc.so.6(GLIBC_2.14)(64bit)
libc.so.6(GLIBC_2.4)(64bit)
libc.so.6(GLIBC_2.3.4)(64bit)
libpthread.so.0()(64bit)
libc.so.6(GLIBC_2.3)(64bit)
libpthread.so.0(GLIBC_2.2.5)(64bit)
libstdc++.so.6()(64bit)
libstdc++.so.6(GLIBCXX_3.4)(64bit)
libstdc++.so.6(CXXABI_1.3)(64bit)
libm.so.6()(64bit)
libm.so.6(GLIBC_2.2.5)(64bit)
libQtCore.so.4()(64bit)
libQtGui.so.4()(64bit)
libkdecore.so.5()(64bit)
libkdeui.so.5()(64bit)
libkio.so.5()(64bit)
libz.so.1()(64bit)
libQtDBus.so.4()(64bit)
libQtXml.so.4()(64bit)
libkparts.so.4()(64bit)
libQtNetwork.so.4()(64bit)
libfreetype.so.6()(64bit)
libQtSvg.so.4()(64bit)
**libphonon.so.4()(64bit)**
libjpeg.so.62()(64bit)
libjpeg.so.62(LIBJPEG_6.2)(64bit)
libsolid.so.4()(64bit)
libkhtml.so.5()(64bit)
libtiff.so.5()(64bit)
libkprintutils.so.4()(64bit)
libkpty.so.4()(64bit)
libthreadweaver.so.4()(64bit)
libqca.so.2()(64bit)
libqimageblitz.so.4()(64bit)
libokularcore.so.1()(64bit)
libkjsapi.so.4()(64bit)
libpoppler-qt4.so.4()(64bit)
libchm.so.0()(64bit)
libspectre.so.1()(64bit)
libdjvulibre.so.21()(64bit)
libepub.so.0()(64bit)
libqt4-x11 >= 4.8.1
**kdebase4-runtime >= 4.8.5**
config(okular) = 4.8.5-2.4.1
/sbin/ldconfig

This is for the latest version and I do wonder about the KDE4 requirement, but none the less, **libphonon.so.4 **is in there as well. Perhaps you could switch to ACROREAD instead of using Okular? One thing is for sure, you have decided to switch to KDE3 & unload Pulseaudio, so any issue you have now is not a bug with the openSUSE 12.2 release. Maybe a different PDF reader will do the trick for you?

Thank You,

Don’t know about that guide but Okular is working perfect here with pulseaudio disabled and uninstalled.

As for how i disabled pulseaudio … first I went into Yast and then in sound card config I unchecked ‘Use pulse audio for this card’ (something like that is in there for pulseaudio configuration, select your card then in ‘Other’ you will see it)
Then in software manager I just marked pulse-audio for removal and that was all.
Can’t remember if there were any dependencies warnings when I marked that for removal but I’m 99% certain that there wasn’t any warnings.

Though I’m running KDE 4.8.5 (you said you are on 3.5 , which is bizarre but maybe it’s a typo) if that even matters.
Kernel I’m running is 3.7.6-2

Nice guess: to assist blind readers.

Evil guess: to hear ************* :smiley:

Thanks for the tip! Is this from the dependencies displayed in SW Management of yast? I’ll try to figure out how this relates.

Well, I was happy with acroread3, but later versions failed too often to display texts from Asia, or print readable text…I had to remove its config files weekly. Now I don’t install it anymore. Okular was my next choice, though it has trouble with some postscript printers and transparency (can’t tell if it is okular itself or something on the long way to the printer). Well…next choice is probably Evince.

The decision against acroread or KDE4 is based on the inverse Moores law which you seem to know as well :wink:

Thanks
Guenter

Hmmm…
Yast2->Sysconfig editor -> Soundcard -> PULSEAUDIO_ENABLE=“no”
Yast2->Sound->“Other” button has a PulseAudio configuration which doesn’t work at the moment

I’ll try to reinstall PulseAudio and disabe it there…
Thanks for the tip!

No, KDE3.5 is real. It’s from Index of /repositories/KDE:/KDE3/openSUSE_12.2 Beside missing some few bits in KDE4 such as the built-in image viewer in konqueror and the kworldclock I have no idea how to work efficiently with KDE4. I couldn’t get friend with plasmoids or the icon window which I can’t get in front of open windows…small issues probably, but enough for me to think that KDE4 is bizarre :wink: I highly appreciate the effort to keep KDE3 alive!

to view Asian text reliably in Acroread you need to install additional files

specifically the acroread font for the language you require (non-oss repo contains acroread fonts for Japanese, Korean and Chinese).
Also you need to install acroread-cmaps (also in the non-oss repo)

And yet you use okular which is a KDE4 application, has the KDE4 workflow all over it. I don’t get it. If we were talking about KDE4 4.0, I could understand, but these days KDE4 has outgrown KDE3 by far, IMHO.

Depending on your needs, PDFViewer may suit; this is also a QT4 based program.

Well, I put the libpulse* back where they belong to, reinstalled the pulseaudio package, double checked that the yast2 sound setting has PulseAudio disabled. So far everything works. No audio blocking with web radio, vlc, skype etc., and okular is also happy.

In summary, I have now libpulse-mainloop-glib0, libpulse0, libpulse0-32bit, pulseaudio packets installed, the above sysconfig setting set to “no”, and the soundcard configured not to use Pulse.

Thanks again for the tip!