run nvidia on optimus (bumblebee) laptop


I have an ASUS N550J optimus laptop, mostly used as desktop.

I installed all the necessary stuff and it works: optirun glxspheres gives 3x the intel speed…

But the default video card is always intel, when I would like to have

  • intel when on battery
  • nvidia when on AC

how can I acheive this?


Maybe use primus. Bumblebee uses Intel unless you explicitly use NVIDIA for a program. Primus allows switching then boot. But not sure Primus is available in 42.3

I guess I have a lot to read on the arch wiki to follow this



I guess I better understand what is optimus, now. Reading doc is hard because it’s most obsolete, the subject being in large evolution.

optimus is an Intel graphic system that can call a nvidia chip on demand. The nvidia is not a true graphic card, at least on my computer (xrandr don’t even see it when optirun do), simply an accelerator.

So it’s not possible to use nvidia as main graphic card, and one have to add “optirun” in front of the command line to use it with an application. Too bad…

I didn’t use the proprietary driver. I try to avoid it because in the past I had a lot of problems with it, and Nouveau works much better now than what it use to do.


Hi, N551 here. Confirming that on our laptops all video outputs are wired to the Intel chip, the Nvidia GPU being used as a graphic accelerator (and openCL compute engine if you install the right stuff).
I did a few experiments in the past, then reverted back to plain bumblebee (I’m not a game addict); I don’t know of any setup that allows switching GPU automatically based on AC or DC power.
I tested suse-prime with Leap 42.1 and then current Tumbleweed, but many things have changed (notably glvnd with the proprietary driver) so maybe it doesn’t work with 42.3 or current TW.
Anyway I had to always boot in “Intel” mode, then possibly “select nvidia”, log out and back in to use Nvidia for all applications in the session.

I tried dri-prime with the Nouveau driver, some results available at
Please be aware that you need a recent kernel and Xorg server/Mesa graphics stack for all that to work, so current TW should be OK, while Leap 42.3 might require extra packages (at least a newer kernel, I think).

I also tried a direct install of the Nvidia driver “the hard way”, using Nvidia for all applications with no option to revert to Intel (suitable for “desktop” use). There I had to change the display manager to lightdm and tweak its configuration, so be careful and do not play with it on your main “work” install since it is quite easy to bork the system unless you are used to tinker with graphics HW.
Login or suspend troubles aside, that install gave me the best speed of all, since the Nvidia chip managed natively all graphics loads and Intel was only used to connect to the video outputs.

Hope this helps.