run NetatmoWizard_Linux_x86_64 error

on my laptop with leap 15.3 and KDE plasma I would like an executable for my netatmo home temperature controller, it works on cell phone but in linux it gives me this errors, I put it in /home/user/bin but it needs root privileges, so I passed to konsole in root mode and this is the result, how can I have this executable working?

pla4-TW:/home/pla/bin # ./NetatmoWizard_Linux_x86_64
QGtkStyle was unable to detect the current GTK+ theme.
QSslSocket: cannot resolve CRYPTO_num_locks
QSslSocket: cannot resolve CRYPTO_set_id_callback
QSslSocket: cannot resolve CRYPTO_set_locking_callback
QSslSocket: cannot resolve sk_free
QSslSocket: cannot resolve sk_num
QSslSocket: cannot resolve sk_pop_free
QSslSocket: cannot resolve sk_value
QSslSocket: cannot resolve SSL_library_init
QSslSocket: cannot resolve SSL_load_error_strings
QSslSocket: cannot resolve SSLv3_client_method
QSslSocket: cannot resolve SSLv23_client_method
QSslSocket: cannot resolve SSLv3_server_method
QSslSocket: cannot resolve SSLv23_server_method
QSslSocket: cannot resolve OPENSSL_add_all_algorithms_noconf
QSslSocket: cannot resolve OPENSSL_add_all_algorithms_conf
QSslSocket: cannot resolve SSLeay
QSslSocket: cannot call unresolved function CRYPTO_num_locks
QSslSocket: cannot call unresolved function CRYPTO_set_id_callback
QSslSocket: cannot call unresolved function CRYPTO_set_locking_callback
QSslSocket: cannot call unresolved function SSL_library_init
QSslSocket: cannot call unresolved function SSLv23_client_method
QSslSocket: cannot call unresolved function sk_num
unsupported date format detected
unsupported date format detected
Segmentation fault (core dumped)



When you ask about third party program you should always provide link to the site where you downloaded this program from and which contains setup instructions. You may have missed or misunderstood something in these instructions. It is naive to expect everyone on this forum to be familiar with every exotic binary out there.

pla4-TW:/home/pla/bin # ./NetatmoWizard_Linux_x86_64
QGtkStyle was unable to detect the current GTK+ theme.
QSslSocket: cannot resolve CRYPTO_num_locks
QSslSocket: cannot resolve CRYPTO_set_id_callback
QSslSocket: cannot resolve CRYPTO_set_locking_callback
...

Installing openssl-1_0_0 may help.

sorry but I thougt that the errors were indipendent from software, the netatmo site before allow to connect to own profile and control the netatmo via browser, now it seems to request a software to do the same thing, netatmo doesn’t gives instructions, when I click on my profile going here:
https://my.netatmo.com/app/station
I only get this:
https://paste.opensuse.org/35136928

tranlated in english:

Download dell’assistente di installazione=download of installation assistant

Stazione Meteo Netatmo=meteo station Netatmo

Scopri il prodotto=discover the product

Per installare la tua Stazione Meteo Netatmo o per configurare i tuoi parametri wifi, scarica l’assistente di installazione Netatmo.=to install your Netatmo meteo station or to configure your wifi parameters download the Netatmo installation assistant

Mostra gli operating systems compatibili=show compatible operating systems

Linux 64 bits (2.6.32 kernel minimum)=Linux 64 bits (2.6.32 kernel minimum)

openssl is already installed

openssl - Secure Sockets and Transport Layer Security
Installed Version
1.1.1d-1.46

That is not the version I told you about. If you need to ask for help, why do not you just try to follow advice?

sorry I didn’t understood that the version was important, or are them different software?
I tried but if I install openssl-1_0_0 yast propose me to uninstall this packages:

#### YaST2 conflicts list - generated 2022-01-25 04:12:43 ####

the to be installed openssl-1_0_0-1.0.2p-3.46.2.x86_64 conflicts with 'namespace:otherproviders(ssl)' provided by the installed openssl-1_1-1.1.1d-11.38.1.x86_64


     ] Following actions will be done:
deinstallation of openssl-1_1-1.1.1d-11.38.1.x86_64
deinstallation of openssl-1.1.1d-1.46.noarch
deinstallation of pesign-obs-integration-10.1-13.3.1.x86_64
deinstallation of mokutil-0.4.0-4.3.1.x86_64
deinstallation of kernel-syms-5.3.18-59.37.1.x86_64
deinstallation of kernel-syms-5.3.18-59.34.1.x86_64
deinstallation of kernel-syms-5.3.18-59.27.1.x86_64
deinstallation of kernel-syms-5.3.18-59.24.1.x86_64
deinstallation of kernel-syms-5.3.18-59.19.1.x86_64
deinstallation of dkms-2.3-bp153.1.17.noarch
deinstallation of tuxedo-keyboard-3.0.9-1.noarch
deinstallation of tuxedo-control-center-1.1.2-1.x86_64
     ] do not install openssl-1_0_0-1.0.2p-3.46.2.x86_64
I think I need at least tuxedo-keyboard and I'm afraid when something uninstall something with kernel inside the name.
is it safe to follow yast ?






#### YaST2 conflicts list END ###

So OpenSSL 1.0 and OpenSSL 1.1 packages are mutually exclusive. But you can install just the libraries from OpenSSL 1.0:

zypper in libopenssl1_0_0

Those libraries provide missing symbols.

Hi, libopenssl1_0_0 result already installed:
in yast libopenssl1_0_0 - Secure Sockets and Transport Layer Security

Installed Version
1.0.2p-3.46.2

Try installing libopenssl1_0_0-devel. If still does not work, run “strace -f -o /tmp/strace.log ./NetatmoWizard_Linux_x86_64” and post full /tmp/strace.log.

Hi, manythanks for the help, I cannot find in my repositories libopenssl1_0_0-devel and neither in:
https://software.opensuse.org/search?utf8=✓&baseproject=ALL&q=libopenssl1_0_0
in my repositories using yast I have:

libopenssl1_0_0-hmac - HMAC files for FIPS-140-2 integrity checking of the openssl shared libraries
The FIPS compliant operation of the openssl shared libraries is NOT possible without the HMAC hashes contained in this package!

libopenssl1_0_0-steam - Secure Sockets and Transport Layer Security for steam
OpenSSL is a software library to be used in applications that need to secure communications over computer networks against eavesdropping or need to ascertain the identity of the party at the other end. OpenSSL contains an implementation of the SSL and TLS protocols.
This subpackage is providing special patched edition for steam

are there all (libopenssl1_0_0) in 32 and 64 bit version, is this relevant?

Yes, this is libopenssl-1_0_0-devel, sorry, but it seems to conflict with OpenSSL 1.1. So post results of strace.

Hi, here is as root:

 pla4-TW:/home/pla/bin # strace -f -o /tmp/strace.log ./NetatmoWizard_Linux_x86_64QGtkStyle was unable to detect the current GTK+ theme.
QSslSocket: cannot resolve CRYPTO_num_locks
QSslSocket: cannot resolve CRYPTO_set_id_callback
QSslSocket: cannot resolve CRYPTO_set_locking_callback
QSslSocket: cannot resolve sk_free
QSslSocket: cannot resolve sk_num
QSslSocket: cannot resolve sk_pop_free
QSslSocket: cannot resolve sk_value
QSslSocket: cannot resolve SSL_library_init
QSslSocket: cannot resolve SSL_load_error_strings
QSslSocket: cannot resolve SSLv3_client_method
QSslSocket: cannot resolve SSLv23_client_method
QSslSocket: cannot resolve SSLv3_server_method
QSslSocket: cannot resolve SSLv23_server_method
QSslSocket: cannot resolve OPENSSL_add_all_algorithms_noconf
QSslSocket: cannot resolve OPENSSL_add_all_algorithms_conf
QSslSocket: cannot resolve SSLeay
QSslSocket: cannot call unresolved function CRYPTO_num_locks
QSslSocket: cannot call unresolved function CRYPTO_set_id_callback
QSslSocket: cannot call unresolved function CRYPTO_set_locking_callback
QSslSocket: cannot call unresolved function SSL_library_init
QSslSocket: cannot call unresolved function SSLv23_client_method
QSslSocket: cannot call unresolved function sk_num
Segmentation fault (core dumped)
pla4-TW:/home/pla/bin # 

/tmp/strace.log. is here:
https://paste.opensuse.org/65892570

Well, it does not try to open libssl 1.0, it goes straight to libssl 1.1. Sorry, this is closed source program and we have no way to troubleshoot it. May be someone else will have an idea.