RTL8191SE driver on Compaq Presario CQ62

No wireless networking. The ethernet works fine, and the wireless interface itself works well in Windows 7 (dual boot).

Ndiswrapper, notoriously quirky, does not seem to work with the XP driver (the oldest driver available for the RTL8191SE).

The linux driver offered on the manufacturer’s website lacks any installation instructions. I have no clue how to install a linux driver.

SUSE seems to have two network managers that are constantly complaining about control: Network Manager and Yast. Neither are great and I am left missing my Ubuntu.

However, my audio only seems to work on SUSE. I have tried almost every distro on this machine. Ubuntu lacked sound and wireless, Fedora played startup sounds, but would not play an mp3 or wav file (fiddling with the mixer did not help). And Fedora also lacked wireless support. PCLinuxOS, my favorite, lacked sound and wireless. Tried some oldies too. ELE, DSL, Puppy, Ubuntu Netbook remix, Vector, Browserpuppy, Crunchbang, Cruncheee (just for experimental sakes) and probably others I am not remembering. So far, installing a free linux distro has cost me 14 dvd-R’s and countless hours of installing, reformatting and reinstalling.

Part of me really wanted crunchbang to work, as I love the minimalism and blacked-out theme.

I need wireless network access. The wireless light remains red in Linux and pressing the key does nothing to start the device. In Windows 7 it always lights white and works perfectly.

Why hasn’t SUSE adopted a gui for ndiswrapper? Other distros have it.
Why is my brand new laptop, which is by no means abnormal in make or configuration, not 100% supported natively by any Linux distro?

I just updated to the new kernel yesterday. So I should be running the most modern operating system available. Yet good-ol Windows 7 is my only fully functional environment.

It would help if you read the sticky posts and posted the output from the commands there.
Ndiswrapper should be a last resort. Most cards shouldn’t need it.
Post the output from

uname -r

Post the output from

cat /etc/SuSE-release

Does your NIC use USB? If so, post the output from


If your nic is pci, post the output from

lspci -nnk 

Post the output from

dmesg |grep firmware 

Once you get all that we’ll work from there.

Wow. Guess I should have expected that. Should have known that the GUI interface of ndiswrapper was the last resort, and that the normal way of solving such and issue is to be typing in cryptic code at command-line like it is 1985. This is your LATEST release (downloaded last week)?

However, let me add that I DO have a linux driver, from the manufacturer website.
Of course, nobody has been clever enough to create a GUI to INSTALL drivers in Linux. So where do I put this thing? The file name is rtl8192se_linux-2.6.0018.1025.2010.tar.gz . Yikes. In windows you simply double click it and it opens into a new folder showing a whole mess of files and documents. Where do I throw all this stuff? I suppose there is some folder with a nonsensical random name (like bin or etc) that I am to simply drop these into (if the folder lets me actually modify its contents).

RTL8191SE is a Single-Chip IEEE 802.11b/g/n 1T2R WLAN Controller with PCI Express Interface. lets approach it like we are dealing with an actual operating system. A GUI would be nice, but I do realize I am dealing with Linux so I won’t press my luck.

Not easier than Windoze yet. Keep up the work guys. I only criticize because I want you all to kick butt. Looks great. I love KDE and E17. Just trying to find the platform to run them on.

You can download the firmware and drivers here (the driver you have would have to be compiled, and yes that requires the command line)…
software.opensuse.org: Search Results

You’ll probably notice it does have an option for one click install. You need to make sure you download the correct driver though.

Use the command (yes from the command line)

uname -r 

Which will give you output something like this


In this case, you want the rtl8192se-kmp-default 32 bit package (in other words, match up which kernel you’re running with the package you need to download).
You’ll need the rtl8192se-firmware package also.

Not difficult at all, and you might learn something while you’re at it.

thanks. I will give it a shot. no doubt the linux driver that I manually compile will work better than an ndiswrapper ‘patch job’.

I am reasonably intelligent. I have just had no luck doing anything in command line in linux. always due to the computer lacking the module or command I am told to use. Like “make command not found”.

Still, I love using linux on my server and my eeepc netbook, both of which work perfectly so I remain optimistic.

Ironically, it is my newest laptop that is giving me these issues. I noticed that sound doesn’t work either. Ugh. I am pretty sure I will figure that out. I have a lot more experience in diagnosing sound issues. Seems easier.

I will let you know what solutions work as I try them. Thank you for the help. This is exactly how forums should be for ALL linux distros.

Yeah, I guess we assume a lot of times with the commands. Make isn’t installed by default, so you would have to install it first.

zypper in make

As an alternative (takes longer IMO) you could use yast to search for the make package and install it.

But, you shouldn’t have to compile anything just yet for your wireless. I’m not sure if you missed my link above, but it links to precompiled driver and firmware packages. (Ask if you need more help with that)

The newer hardware usually causes problems in Linux because the manufacturers don’t supply drivers and it takes a while for developers to make their own. But overall, hardware if fairly well supported in linux.

Speaking of compaq drivers, I get mine from this compaq drivers site. It also has driver search tool using google custom search technology that helps locate the right driver for my computer model.