RTL8188CE / RTL8192CE confusion & loss of connection


after months of trying to solve this on my own, I give up. I have a Thinkpad T530,
which has a Realtek wireless adapter, which works only intermittently, often
the connection freezes after minutes. /etc/init.d/network restart can fix it,
but not for long. Everything works smoothly under Windows.

dmesg tells

userif-3: sent link up event.<6>[14898.656098] wlan0: deauthenticating from 00:0c:e6:48:07:01 by local choice (reason=3)

Searching the web, there seems to be a history of problems with this card,
but I could not find any fix that really solved it. Here some background:

I’m running Suse 12.3, kernel 3.7.10-1.11-desktop.

lspci -nn

03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter [10ec:8176] (rev 01)

lsmod | grep rtl
rtl8192ce 146497 0
rtlwifi 131616 1 rtl8192ce
mac80211 598150 2 rtl8192ce,rtlwifi
cfg80211 218484 2 rtlwifi,mac80211

thus, my first confusion: am I using the right driver module? If not - how do I configure
Suse to load the correct module?

It seems to me that things got worse after the latest kernel update (but that may
just be a subjective impression) to a point that I can’t work any more and
my colleagues with a Mac are just laughing their heads off.

The closest I get to a solution is downloading the latest driver from Realtek,


compiling and installing it,

modinfo rtl8192ce
filename: /lib/modules/3.7.10-1.11-desktop/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko
firmware: rtlwifi/rtl8192cfw.bin
description: Realtek 8192C/8188C 802.11n PCI wireless
license: GPL
author: Larry Finger <Larry.Finger@lwfinger.net>
author: Realtek WlanFAE <wlanfae@realtek.com>
author: lizhaoming <chaoming_li@realsil.com.cn>
srcversion: 8371CA3A9E899B11125FFDE
alias: pci:v000010ECd00008176svsdbcsci*
alias: pci:v000010ECd00008177svsdbcsci*
alias: pci:v000010ECd00008178svsdbcsci*
alias: pci:v000010ECd00008191svsdbcsci*
depends: rtlwifi,mac80211
vermagic: 3.7.10-1.11-desktop SMP preempt mod_unload modversions
parm: swlps:bool
parm: swenc:using hardware crypto (default 0 [hardware])
parm: ips:using no link power save (default 1 is open)
parm: fwlps:using linked fw control power save (default 1 is open)

While this is at least not dropping off the wireless every minute, it is still very
bumpy and unreliable.

Thus, my second question: is it me, or is there some persisting problem
with the Realtek adaptor?

Any help much appreciated!

[NB - I’m using Suse since 19 years … this is the first time that I can not
get over a problem, hence the severe level of distress]

Please post the output between CODE tags, the # in the editor. In proportional font spacing the output is virtually unreadable.

EDIT: Just noticed it’s your first post here, welcome !!

On 06/05/2013 03:06 AM, Knurpht wrote:
> Please post the output between CODE tags, the # in the editor. In
> proportional font spacing the output is virtually unreadable.
> EDIT: Just noticed it’s your first post here, welcome !!

In case you do not know, I am the maintainer for that driver. The frequent
disconnects that you are seeing do not happen for me, which makes them extremely
hard to debug. In addition, Realtek has not provided me with any information
regarding the internal operation of the chip, thus it is difficult for me to
understand why events happen.

There are a number of changes in that driver that are present in kernel
3.10-rcX. You can get such a kernel by following the instructions in
http://en.opensuse.org/openSUSE:Kernel_of_the_day. At the moment, 3.10-rc4 is in
that repo.

If you do not want to use the complete new kernel, then you can choose to
implement the drivers using the backports project by downloading the tarball at
This method will preserve your existing kernel, but it will require you to have
all the prerequisites needed to build modules. I recommend that you use the KOTD

Hi,I am having the same problem.

Sorry for getting back to this so (very) late. I tried the kernel of the day, as Larry suggested, and it did seem to improve the connectivity, however, still not satisfying. I’m not sure what the problem is, but I had the feeling that I am not the only one having trouble with the Realtek card, see also the comment on https://wiki.archlinux.org/index.php/Lenovo_ThinkPad_T530 - maybe it’s something specific about the combination of this Thinkpad and the Realtek card.

As I’ve been travelling quite a bit lately, and really depend on the wireless working, I went down another alley: I bought an Intel Ultimate-N 6300 card on e-bay, and substituted the Realtek card - the Intel card performs much, much better. There is one important point to watch out for, if you want to try the same: you will need to make sure you buy a wireless card that is manufactured for the use with Thinkpads, otherwise the BIOS may refuse to work with the card. The Intel card I got
has the Lenovo FRU 60Y3233, search for that number e.g. on e-bay. Removing the wireless card is surprisingly easy: it sits under the keyboard, instructions how to remove the card are here, it’s just four screws that need to be removed to get to the wireless card.