RTL8187 wireless working like a charm :)

Just tried rtl8187 wlan0, which was not, or very badly supported under 10.3 and kernel prior to 2.6.25+, it is awesome under 11.1b2. :slight_smile:

Simple configuration through Yast, installed 2 small packages upon clicking OK and bingo!! :slight_smile: No madwifi and ndiswrapper.

Just make sure your SSID, PW, encryption method and MAC filtering are all matching. I spent over 1 hour trying to figure out why everything was fine in the command line but my connection was not working. I forgot to add the MAC address in my router’s MAC filtering. :stuck_out_tongue: So don’t do such a mistake. :slight_smile: Usually starting simple with no filtering, no encryption, SSID broadcast etc. is better. Then once connection works, add security measures one by one.

Now there is nvidia compiz that says it works but none of the effects are. Still working on that one… So far for a beta it’s quite great and stable on KDE3.5 as an upgrade (not fresh install) from 10.3.

I just connected to my home network with a RTL8187 using only knetworkmanager. No extra packages, just selected my SSID in the list of detected networks, WPA encryption, password and everything worked.

I have to test it with other networks though.