RTL8111DL Ethernet error with kernel-desktop-devel install error

So i have been receiving error 2 when executing make clean or make clean modules
“No rule to make target ‘clean’. stop”
“No rule to make target ‘modulus’. stop”

I figured out i don’t have the kernel-desktop-devel-3.4.6-2.10.rpm installed.

When i attempt to install it through yast, i receive the following error:
“subprocess failed. error rpm failed error unpacking of archive failed on file /lib/modules/3.4.6-2.10-desktop/build: cpio:rename failed - is a directory error: kernel-desktop-devel-3.4.6-2.10.1.x86_64:install failed”

I tried another copy of the kernel-desktop-devel-3.4.6-2.10.1.rpm file and continue to receive the same error.

The whole issue is that i have an ASROCK 880GM-LE mobo that has built in realtek RTL8111DL ethernet port.

Honestly, this is my first time messing with linux and i am learning quite a bit from the forums and google.

If this is in the wrong sub-forum, i apologize. Please point me in the right direction.
Thanks.

Hello, welcome.

We like it very much when you at least tell us which level of openSUSE you use.

Also, when you post computer text from a terminal, copy/paste this including the prompts (at begin and end) and the command used between CODE tags (using the # button from the toolbar).

Sorry about that.

OpenSuse 12.2 64bit

The yast error is as follows:


Subprocess failed. Error: RPM failed: error: unpacking of archive failed on file /lib/modules/3.4.6-2.10-desktop/build: cpio: rename failed - Is a directory
error: kernel-desktop-devel-3.4.6-2.10.1.x86_64: install failed

The make clean modules error is as follows:


linux-2g97:~/r8168-8.034.00 # make clean modules
make -C src/ clean
make[1]: Entering directory `/root/r8168-8.034.00/src'
make -C /lib/modules/3.4.6-2.10-desktop/build SUBDIRS=/root/r8168-8.034.00/src clean
make[2]: Entering directory `/lib/modules/3.4.6-2.10-desktop/build'
make[2]: *** No rule to make target `clean'.  Stop.
make[2]: Leaving directory `/lib/modules/3.4.6-2.10-desktop/build'
make[1]: *** [clean] Error 2
make[1]: Leaving directory `/root/r8168-8.034.00/src'
make: *** [clean] Error 2
linux-2g97:~/r8168-8.034.00 # 
 



What makes you think you need to install this driver?

And what do you mean by “an other copy of…”. There should be none, or you installed a version that does not match your running kernel.
Since you’re new: pleaese don’t believe the stories that you have to compile every single driver yourself. My bet is that it’s a configuration issue, rather than a missing driver.

well i didnt have the kernel-source, module-init-tools, or gcc installed either. After reading around that’s what I figured i needed to install. After installing them all with the exception of the kernel-desktop-devel, I was able to actually execute the make command. Then looking online everyone mentioned that missing headers are typical for the No rule to make target clean error.

What i mean by another copy is i thought the one on my dvd was corrupt so i downloaded the same version of the rpm and tried installing it.

As for the driver. I have no ethernet detected. I read on here that the RTL8111 has issues with openSuse. Digging around on other forums I found a guide on how to change my driver from the r8169 to the r8168. I figured it wouldn’t hurt to try, and if it worked, great.

It’s a fresh install. I have no problems formatting and starting over.

Well, i reinstalled openSuse 12.2 with the basic developer package and c++ package and now it seems to detect my eth0 from yast but not the network configuration system settings.

I set the ip address in yast 192.168.2.104 but no internet. I can ping my gateway and other devices on the LAN.

Thanks for the help on my other issue. Now i’ll try and figure out why i can’t navigate the internet.

When you say you set the IP address, that means to me that you do not use DHCP. And that again means that you do have to configure everything needed. Not only the IP address, but also the deafult gateway. Else how could the system ever find the Internet? And you most probably also have to configure your DNS server(s), else you would only be able to go to systems on the internet by IP address and not by host.domainname.

Look at the other tabs in YaST > Network devices > Network Setings.

On Sat 17 Nov 2012 03:26:01 PM CST, shotty53 wrote:

Well, i reinstalled openSuse 12.2 with the basic developer package and
c++ package and now it seems to detect my eth0 from yast but not the
network configuration system settings.

I set the ip address in yast 192.168.2.104 but no internet. I can ping
my gateway and other devices on the LAN.

Thanks for the help on my other issue. Now i’ll try and figure out why
i can’t navigate the internet.

Hi
If you set a static ip address, you also need to add the gateway and
dns servers in the configuration.


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.2 (x86_64) Kernel 3.4.11-2.16-desktop
up 1:25, 4 users, load average: 0.02, 0.04, 0.08
CPU Intel i5 CPU M520@2.40GHz | Intel Arrandale GPU

Thank you very much every. I’m all up and running.
I appreciate the help. lol!