RTC device isn't available

I’m trying to set an ACPI wakeup alarm but there seems to be no RTC device available anywhere.

localhost:/ # rtcwake --seconds 1
rtcwake: /dev/rtc0: unable to find device: No such file or directory
localhost:/ # ls /dev | grep rtc
localhost:/ # ls /sys/class/rtc
localhost:/ # hwclock --debug
hwclock from util-linux 2.30.1
Trying to open: /dev/rtc0
Trying to open: /dev/rtc
Trying to open: /dev/misc/rtc
No usable clock interface found.
hwclock: Cannot access the Hardware Clock via any known method.

I’ve tried modprobbing rtc-cmos/rtc_cmos/genrtc, enabling hpet in GRUB and just about every answer I could find on Google. None of that worked.

localhost:/ # lsmod | grep rtc
localhost:/ # hwinfo | grep rtc
  <6>    2.928656] rtc_cmos 00:01: RTC can wake from S4
  <4>    2.928687] rtc_cmos: probe of 00:01 failed with error -16
  <6>    2.986194] hctosys: unable to open rtc device (rtc0) 

I’m using Tumbleweed.

localhost:/ # uname -a
Linux localhost.localdomain 4.13.9-1-default #1 SMP PREEMPT Mon Oct 23 09:44:25 UTC 2017 (e7d7106) x86_64 x86_64 x86_64 GNU/Linux

Some kernel guru out there please help me!

So this seems to be a driver related bug introduced in kernel 4.13. It affects some chipsets in the Broadwell family and possibly other Intel families too. In my case, the CPU is an i5 5200U, on an Insyde-based Acer EA50_HB motherboard. Insyde is also prominent with Dell motherboards.

So the solution was to downgrade the kernel to 4.12.x.

A pre-built 4.12.14 kernel package (at the time of this writing) is available at https://build.opensuse.org/package/show/Kernel%3ASLE15/kernel-default

I wish someone in the core dev team would have a look at this and maybe patch it downstream if possible.

Report to bugzilla or it does not get fixed we are just users here