rt61pci driver broken - random disconnects and 1MB rate???


So, I have a wireless card that uses the rt61pci driver. Unfortunately it randomly disconnects from the network and throttles to 1MB. Ummmm WTF!!!


There are like 10 threads about it already, how about using the search.

I am logging this as an 11.2 rant :wink: Been broken for a verrrryyyyy long time, aaa vvveeeeeerrrryyyy llloooonnnnnggggg ttttiiiimmmmeee. I have filed a bug with the kernel guys but I get the feeling from the thread they don’t know what happened between the kernel updates. Lots of diff files and the such but nothigns working… sigh

sudo /usr/sbin/iwconfig wlan0 rate 48M

works for me. Of course having to enter this every time is a slight nuisance :X

Ahhhh but the card also randomly disconnects from the internet and I cannot reconnect for at least 5 minutes, then I am back to 1MB heaven :slight_smile:

Before the 2.6.3x series everything was fine… on stupid wired when I travel now :frowning:

Have you tried.

iwconfig wlan0 power off
iwconfig wlan0 txpower auto


At least in my network card the power management is completely borked and I need the above commands to get started at all. Maybe your disconnects have to do with power management, too? Just a wild guess, but best of luck to you :wink:

Thanks! that last one worked for me… and it’s been working for two days!

Here’s what I did to make it run when it reboots or when NetworkManager puts it up again:

I created a script which I named zzzwlan0 and I put it in /etc/network/if-up.d/ [Caveat! I’m not running Suse :open_mouth: so the location may vary] The zzz part was so that it is the last script that runs.

Anyway, here’s the script, and don’t forget to make it chown root:root and chmod 755

#! /bin/sh
set -e

## This was put in by jose on 20091119 to fix the problem
## with the wireless card dying after a while...

# Only run from ifup.
if  "$MODE" != "start" ]; then
        exit 0

if  "$METHOD" != "NetworkManager" ]; then
        exit 0

if  "$IFACE" = wlan0 ]; then
        iwconfig wlan0 power off
        iwconfig wlan0 txpower auto
exit 0