rt2x00lib_request_firmware: Error

11.2 KDE RT2561 PCI

Seems that although the firmware is available,
file:///lib/firmware/rt2561.bin, file:///lib/firmware/rt2561s.bin, it can’t be accessed by the kernel.

Anyone have an idea as to why?


Yast Network Settings:
… snip …
RT2561/RT61 802.11g PCI
MAC : 00:1f:1f:05:ca:c0
BusID : 0000:05:01.0

Device Name: wlan0
Started automatically at boot
IP address assigned using DHCP

hwinfo --wlan
23: PCI 501.0: 0282 WLAN controller
[Created at pci.318]
UDI: /org/freedesktop/Hal/devices/pci_1814_301
Unique ID: y9sn.gohsp1cSoiA
Parent ID: 6NW+.two+GgbUMg7
SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:05:01.0
SysFS BusID: 0000:05:01.0
Hardware Class: network
Model: “RaLink EW-7108PCg”
Vendor: pci 0x1814 “RaLink”
Device: pci 0x0301 “RT2561/RT61 802.11g PCI”
SubVendor: pci 0x1814 “RaLink”
SubDevice: pci 0x2561 “EW-7108PCg”
Driver: “rt61pci”
Driver Modules: “rt61pci”
Device File: wlan0
Features: WLAN
Memory Range: 0xfb000000-0xfb007fff (rw,non-prefetchable)
IRQ: 19 (no events)
HW Address: 00:1f:1f:05:ca:c0
Link detected: yes
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
WLAN encryption modes: WEP40 WEP104 TKIP CCMP
WLAN authentication modes: open sharedkey wpa-psk wpa-eap
Module Alias: “pci:v00001814d00000301sv00001814sd00002561bc02sc80i00”
Driver Info #0:
Driver Status: rt61pci is active
Driver Activation Cmd: “modprobe rt61pci”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #15 (PCI bridge)

/sbin/lspci: -v
… snip …
05:01.0 Network controller: RaLink RT2561/RT61 802.11g PCI
Subsystem: RaLink EW-7108PCg
Flags: bus master, slow devsel, latency 32, IRQ 19
Memory at fb000000 (32-bit, non-prefetchable) [size=32]
Capabilities: [40] Power Management version 2
Kernel driver in use: rt61pci

dmesg | less
… snip …
19.699517] r8169: eth0: link up
19.699525] r8169: eth0: link up
20.877911] NET: Registered protocol family 17
24.239835] rt61pci 0000:05:01.0: firmware: requesting rt2561s.bin
84.239172] phy0 → rt2x00lib_request_firmware: Error - Failed to request Firmware.
86.166652] CPU0 attaching NULL sched-domain.
86.166656] CPU1 attaching NULL sched-domain.
86.169175] CPU0 attaching sched-domain:
86.169177] domain 0: span 0-1 level MC
86.169179] groups: 0 1
86.169183] CPU1 attaching sched-domain:
86.169185] domain 0: span 0-1 level MC
86.169186] groups: 1 0
90.183743] rt61pci 0000:05:01.0: firmware: requesting rt2561s.bin
150.183045] phy0 → rt2x00lib_request_firmware: Error - Failed to request Firmware.
150.185078] rt61pci 0000:05:01.0: firmware: requesting rt2561s.bin
210.185170] phy0 → rt2x00lib_request_firmware: Error - Failed to request Firmware.
211.492808] BIOS EDD facility v0.16 2004-Jun-25, 1 devices found

Kernel log:
… snip …
2010-03-14 14:08:36 r8169 eth0: link up
2010-03-14 14:08:36 r8169 eth0: link up
2010-03-14 14:08:37 NET Registered protocol family 17
2010-03-14 14:08:41 rt61pci 0000 5:01.0: firmware: requesting rt2561s.bin
2010-03-14 14:09:41 phy0 → - Failed to request Firmware.
2010-03-14 14:09:43 CPU0 attaching NULL sched-domain.
2010-03-14 14:09:43 CPU1 attaching NULL sched-domain.
2010-03-14 14:09:43 CPU0 attaching sched-domain:
2010-03-14 14:09:43 domain 0 span 0-1 level MC
2010-03-14 14:09:43 groups 0 1
2010-03-14 14:09:43 CPU1 attaching sched-domain:
2010-03-14 14:09:43 domain 0 span 0-1 level MC
2010-03-14 14:09:43 groups 1 0
2010-03-14 14:09:47 rt61pci 0000 5:01.0: firmware: requesting rt2561s.bin
2010-03-14 14:10:47 phy0 → rt2x00lib_request_firmware: Error - Failed to request Firmware.
2010-03-14 14:10:47 rt61pci 0000 5:01.0: firmware: requesting rt2561s.bin
2010-03-14 14:11:47 phy0 → rt2x00lib_request_firmware: Error - Failed to request Firmware.
2010-03-14 14:11:48 BIOS EDD facility v0.16 2004-Jun-25, 1 devices found[/size]