RT2573 "Wireless disabled by Hardware" --- but it's not

I recently installed openSUSE 12.2 on an MSI VR420 laptop (model MS-1422). Since it is a laptop, I elected to go with the Network Manager applet rather than using ifup/ifdown. Fortunately I configured it as a dual-boot machine and left the existing Winows Vista Home Premium OS in place.

The problem is that frequently on bootup after a reboot or powerdown Network Manager will report “Wireless disabled by hardware” even though the LED for the radio is illuminated. Indeed, the Wireless LED will toggle by repeatedly depressing the wireless switch. The only way I’ve found to get the WiFi to work when this happens is to reboot into Vista and login so that the WiFi connects to an AP, then reboot into openSUSE. The WiFi will then work and connect to the AP.

Interestingly, I can get the same message when Wifi is working by pressing the wireless switch and extinguishing the WiFi LED.

I have tested the memory extensively using Memtest86+ and the memory test portion of the Vista System Recovery S/W, No errors have been found.

Still, SOMETHING is causing a bit to flip somewhere on openSUSE reboot/shutdown and that bit stays flipped through multiple reboots and removal of the battery and power cable.

If there’s some way to re-enable the WiFi in software (preferably from the command line) I’d like to know it.

Here is the output of “hwinfo --netcard” when WiFi is working and when it’s not. In both cases I cut out the portion that relates to the onboard Gb wired NIC.

hwinfo --netcard (when WiFi is disabled)

11: PCI 19.0: 0200 Ethernet controller
   Deleted]

53: USB 00.0: 0282 WLAN controller
  [Created at usb.122]
  Unique ID: hSuP.kMYwghKIXz8
  Parent ID: pBe4.9T1GDCLyFd9
  SysFS ID: /devices/pci0000:00/0000:00:1d.7/usb2/2-2/2-2:1.0
  SysFS BusID: 2-2:1.0
  Hardware Class: network
  Model: "Micro Star International 802.11 bg WLAN"
  Hotplug: USB
  Vendor: usb 0x0db0 "Micro Star International"
  Device: usb 0x6877 "802.11 bg WLAN"
  Revision: "0.01"
  Driver: "rt73usb"
  Driver Modules: "rt73usb"
  Device File: wlan0
  Features: WLAN
  Speed: 480 Mbps
  HW Address: 00:24:21:42:8f:6c
  Link detected: no
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "usb:v0DB0p6877d0001dc00dsc00dp00icFFiscFFipFF"
  Driver Info #0:
    Driver Status: rt73usb is active
    Driver Activation Cmd: "modprobe rt73usb"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #52 (Hub)

hwinfo --netcard (when WiFi is working)

11: PCI 19.0: 0200 Ethernet controller
   Deleted]

53: USB 00.0: 0282 WLAN controller
  [Created at usb.122]
  Unique ID: hSuP.kMYwghKIXz8
  Parent ID: pBe4.9T1GDCLyFd9
  SysFS ID: /devices/pci0000:00/0000:00:1d.7/usb2/2-2/2-2:1.0
  SysFS BusID: 2-2:1.0
  Hardware Class: network
  Model: "Micro Star International 802.11 bg WLAN"
  Hotplug: USB
  Vendor: usb 0x0db0 "Micro Star International"
  Device: usb 0x6877 "802.11 bg WLAN"
  Revision: "0.01"
  Driver: "rt73usb"
  Driver Modules: "rt73usb"
  Device File: wlan0
  Features: WLAN
  Speed: 480 Mbps
  HW Address: 00:24:21:42:8f:6c
  Link detected: no
  WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 12 13 14
  WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 2.467 2.472 2.484
  WLAN encryption modes: WEP40 WEP104 TKIP CCMP
  WLAN authentication modes: open sharedkey wpa-psk wpa-eap
  Module Alias: "usb:v0DB0p6877d0001dc00dsc00dp00icFFiscFFipFF"
  Driver Info #0:
    Driver Status: rt73usb is active
    Driver Activation Cmd: "modprobe rt73usb"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #52 (Hub)

I’m beginning to think that this is a bug in the rt73usb module, as it seems that the same thing happens when booting a LiveCD (like PartedMagic).

I appreciate any help you can offer. If you need more info let me know.

Thanks,
ron

Windows is leaving the hardware in a state from which Linux cannot recover. When
you get into this state, run the command ‘/usr/sbin/rfkill list’ to see what is
blocking the radio.

You should run ‘sbin zypper install rfkill’ to make sure that the utility is
available before you need it.

You should run ‘sbin zypper install rfkill’ to make sure that the utility is
available before you need it.

If rfkill is not installed, then

sudo zypper in rfkill

Well, wouldn’t you know it.
After installing the latest round of updates last Sunday the machine has yet to fail to boot w/ WiFi disabled.
oh well.

Actually, until the last 2 days, it’s linux that’s leaving the hardware in state from which linux cannot recover.
The only time I booted into Windows was to get the hardware reset to a condition that enabled linux to get the WiFi working.

All in all, it doesn’t matter.

There are so many usability issues (no response to keyboard or mouse clicks for minutes at a time, etc) that I’m thinking that this machine is a poor match for openSUSE, at least with KDE. As an example, the keyboard just timed out for about 30 minutes as I was composing this post.

recently my wifi card was troubled - i could drive it with iwconfig, iwlist, etc… could turn the card off/on and networkmanager would attempt to set the address with dhcp … and the configuration was ‘roughly’ same as had been working that morning …

the error in wpa_supplicant.log said

wlan0: disassociating from nn:nn:nn:nn:nn:nn by local choice (reason=3) 		

my wifi card would never get associated, even with an unsecured access point that was working previously
had also taken the 12.3 beta update and generally been tinkering with my machine recently

one of the two things i did at the same time fixed my issue -

  1. set the ip address manually on wlan0 - because dhcp appeared to be having issues - though possibly was just wating on the card

  2. changed the power_save option to off using this command

    iw wlan0 set power_save off

now wifi is back working as it was… still no bluetooth yet … and that was working too previously … no doubt those are related.

hth,
/j